• 1071 Speech Patterns (25)(25 分)


    People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

    Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

    Input Specification:

    Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return ' '. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

    Output Specification:

    For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

    Note that words are case insensitive.

    Sample Input:

    Can1: "Can a can can a can?  It can!"
    

    Sample Output:

    can 5
    #include<iostream>
    #include<map>
    #include<string>
    using namespace std;
    bool check(char c){
        if(c >= '0' && c <= '9') return true;
        if(c >= 'a' && c <= 'z') return true;
        if(c >= 'A' && c <= 'Z') return true;
        return false;
    }
    int main(){
        map<string,int> count;
        string str;
        getline(cin,str);
        int i = 0;
        while(i < str.length()){
            string word;
            while(i < str.length() && check(str[i]) == true){
                if(str[i] >= 'A' && str[i] <='Z'){
                    str[i] += 32;
                }
                word += str[i];
                i++;
            }
            if(word != " "){
                if(count.find(word)!=count.end()) count[word]++;
                else count[word] = 1;
            }
            while(i < str.length() && check(str[i]) == false){
                i++;
            }
        }
            string ans;
            int max = 0;
            for(map<string,int>::iterator it = count.begin(); it!=count.end();it++){
                if(it -> second > max){
                    ans = it -> first;
                    max = it -> second;
                }
            }
        cout << ans << " " << max << endl;
        return 0; 
    }

    20200104

    最后一个测试点没通过,应该是空符的问题,待排查

    #include<iostream>
    #include<string>
    #include<map>
    using namespace std;
    
    bool check(char c);
    
    int main()
    {
        string str;
        string word;
        map<string, int> mp;
    
        getline(cin, str);
    
        int len = str.length();
    
        for (int i = 0; i < len; i++)
        {
            if (check(str[i]))
            {
                if (str[i] >= 'A' && str[i] <= 'Z')
                {
                    str[i] += 32;
                }
                word += str[i];
                continue;
            }
            else if (word != "" && (!word.empty()))
            {
                if (mp.find(word) != mp.end())
                {
                    mp[word]++;
                }
                else
                {
                    mp[word] = 1;
                }  
                word.clear();          
            }
        }
    
        string ans;
        int max = 0;
        for (auto it = mp.begin(); it != mp.end(); it++)
        {
            if (it->second > max && it->first != "")
            {
                ans = it->first;
                max = it->second;
            }
        }
    
        cout << ans << " " << max << endl;
        return 0;
    }
    
    bool check(char c)
    {
        if (c >= '0' && c <= '9')
        {
            return true;
        }
        else if (c >= 'a' && c <= 'z')
        {
            return true;
        }
        else if (c >= 'A' && c <= 'Z')
        {
            return true;
        }
    
        return false;
    }
  • 相关阅读:
    可左右拖动窗口demo
    制作一个简单的百度网盘在线视频加速的chrome插件
    git分支
    使用git的ssh
    git的概念和常用命令
    爬虫:获取页面 -- request库的使用
    字符串方法
    从实现原理更深入了解call和apply
    Git和GitHub使用
    localStorage和sessionStorage
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/9155072.html
Copyright © 2020-2023  润新知