• 1086. Tree Traversals Again (25)


    An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


    Figure 1

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

    Output Specification:

    For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

    Sample Input:

    6
    Push 1
    Push 2
    Push 3
    Pop
    Pop
    Push 4
    Pop
    Pop
    Push 5
    Push 6
    Pop
    Pop
    

    Sample Output:

    3 4 2 6 5 1
    #include<cstdio>
    #include<stack>
    #include<cstring>
    using namespace std;
    const int maxn = 40;
    struct node{
        int data;
        node* lchild;
        node* rchild;
    };
    int pre[maxn],in[maxn],post[maxn];
    int n;
    node* create(int preL,int preR,int inL,int inR){
        if(preL > preR) return NULL;
        node *root = new node;
        root->data = pre[preL];
        int k;
        for(k = inL; k <= inR; k++){
            if(in[k] == pre[preL]) break;  //输出数值不对要检查判断数值问题 
        }
        int numleft = k - inL;
        root->lchild = create(preL+1,preL+numleft,inL,k-1);
        root->rchild = create(preL+numleft+1,preR,k+1,inR);
        return root;
    }
    int num = 0;
    void postorder(node* root){
        if(root == NULL) return;
        postorder(root->lchild);
        postorder(root->rchild);
        printf("%d",root->data);
        num++;
        if(num < n)printf(" ");
    }
    int main(){
      scanf("%d",&n);
      stack<int> st;
      int x,preIndex = 0,inIndex = 0;
      char str[10];
      for(int i = 0; i < 2*n; i++){
          scanf("%s",str);
          if(strcmp(str,"Push") == 0){
              scanf("%d",&x);
              st.push(x);
              pre[preIndex++] = x;
          }else{
              in[inIndex++] = st.top();
              st.pop();
          }
      }
      node* root = create(0,n-1,0,n-1);
      postorder(root);
      return 0;
    }
  • 相关阅读:
    四则运算出题系统,java
    Javaweb测试
    《构建之法》 读书笔记(6)
    使用ProcDump在程序没有响应时自动收集dump
    NASA关于如何写出安全代码的10条军规
    C#和C++中的float类型
    避免在C#中使用析构函数Finalizer
    C#性能优化的一些技巧
    从bug中学习怎么写代码
    Code Smell那么多,应该先改哪一个?
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/8567000.html
Copyright © 2020-2023  润新知