• 04-树6 Complete Binary Search Tree (30 分)


    A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

    • The left subtree of a node contains only nodes with keys less than the node's key.
    • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
    • Both the left and right subtrees must also be binary search trees.

      A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

      Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

      Input Specification:

      Each input file contains one test case. For each case, the first line contains a positive integer N (≤). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

      Output Specification:

      For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

      Sample Input:

      10
      1 2 3 4 5 6 7 8 9 0
      

      Sample Output:

      6 3 8 1 5 7 9 0 2 4
      #include<cstdio>
      #include<algorithm>
      using namespace std;
      const int maxn = 2010;
      
      int n;
      int index = 0;
      int CBT[maxn],num[maxn];
      
      void inOrder(int root){
          if(root > n) return;
          inOrder(root*2);
          CBT[root] = num[index++];
          inOrder(root*2+1); 
      }
      
      int main(){
      
          scanf("%d",&n);
          for(int i = 0; i < n; i++){
              scanf("%d",&num[i]);
          }
          sort(num,num+n);
          inOrder(1);
          for(int i = 1; i <= n; i++){
              printf("%d",CBT[i]);
              if(i < n) printf(" ");
          }
          return 0;
      }
  • 相关阅读:
    Java基础教程:Java内存区域
    Java基础教程:多线程基础——线程池
    微服务实践:服务治理
    微服务实践:服务设计
    微服务实践:什么是微服务
    SpringBoot学习笔记:读取配置文件
    Java进阶教程:使用Lombok提升开发效率
    Sagas模式
    执行力:Just Do It
    执行力:Just Do It
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/10708696.html
Copyright © 2020-2023  润新知