• 03-树3 Tree Traversals Again (25 分)


    An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


    Figure 1

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (≤) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2 lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

    Output Specification:

    For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

    Sample Input:

    6
    Push 1
    Push 2
    Push 3
    Pop
    Pop
    Push 4
    Pop
    Pop
    Push 5
    Push 6
    Pop
    Pop
    

    Sample Output:

    3 4 2 6 5 1
    #include<cstdio>
    #include<cstring>
    #include<stack>
    using namespace std;
    const int maxn = 35;
    struct Node{
        int data;
        Node* lchild;
        Node* rchild;
    };
    
    int pre[maxn],in[maxn];
    int n,num = 0;
    
    Node* createTree(int preL,int preR,int inL,int inR){
        if(preL > preR) return NULL;
        Node* root = new Node;
        root->data = pre[preL];
        int k;
        for(k = inL; k <= inR; k++){
            if(in[k] == pre[preL]) break;
        }
        int numLeft = k - inL;
        root->lchild = createTree(preL+1,preL+numLeft,inL,k-1);
        root->rchild = createTree(preL+numLeft+1,preR,k+1,inR);
        return root;
    }
    
    void postOrder(Node* root){
        if(root == NULL) return;
        postOrder(root->lchild);
        postOrder(root->rchild);
        printf("%d",root->data);
        num++;
        if(num < n) printf(" ");
    }
    
    
    int main(){
        scanf("%d",&n);
        char str[5];
        int x,preIndex = 0,inIndex = 0;
        stack<int> s;
        for(int i = 0; i < 2*n; i++){
            getchar();
            scanf("%s",str);
            if(strcmp(str,"Push") == 0){
                scanf("%d",&x);
                s.push(x);
                pre[preIndex++] = x;
            }else{
                in[inIndex++] = s.top();
                s.pop();
            }
        }
        Node* root = createTree(0,n-1,0,n-1);
        postOrder(root);
        return 0;
    }
  • 相关阅读:
    【我所认知的BIOS】—&gt; uEFI AHCI Driver(4) — 第一个Protocol真难搞
    IOS Core Animation Advanced Techniques的学习笔记(四)
    Redhat 7改动默认执行级别方法 --RHEL7使用systemd创建符号链接指向默认执行级别
    CF1088F Ehab and a weird weight formula
    2018-2-13-win10-uwp-csdn-博客阅读器
    2018-2-13-win10-uwp-csdn-博客阅读器
    2018-2-13-win10-UWP-九幽数据分析
    2018-2-13-win10-UWP-九幽数据分析
    2019-9-2-win10-uwp-获得焦点改变
    2019-9-2-win10-uwp-获得焦点改变
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/10669756.html
Copyright © 2020-2023  润新知