• [ACM] hdu 1213 How Many Tables(并查集)


    How Many Tables

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 11580    Accepted Submission(s): 5696


    Problem Description
    Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

    One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

    For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
     

    Input
    The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
     

    Output
    For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
     

    Sample Input
    2 5 3 1 2 2 3 4 5 5 1 2 5
     

    Sample Output
    2 4
     

    Author
    Ignatius.L
     

    Source


    解题思路:

    简单的并查集。计算有多少集合。

    代码:

    #include <iostream>
    using namespace std;
    int parent[1002];
    
    void init(int n)
    {
        for(int i=1;i<=n;i++)
            parent[i]=i;
    }
    int find(int x)
    {
        return parent[x]==x?x:find(parent[x]);
    }
    void unite(int x,int y)
    {
        x=find(x);
        y=find(y);
        if(x==y)
            return ;
        else
            parent[x]=y;
    }
    int main()
    {
        int t;cin>>t;
        int n,m;
        int a,b;
        while(t--)
        {
            cin>>n>>m;
            init(n);
            int ans=0;
            for(int i=1;i<=m;i++)
            {
                cin>>a>>b;
                unite(a,b);
            }
            for(int i=1;i<=n;i++)
                if(parent[i]==i)
                ans++;
            cout<<ans<<endl;
        }
        return 0;
    }
    


  • 相关阅读:
    audio之点击图标切换音频播放状态以及替换当前图标
    js之ajax的封装
    JavaScript之ajax的作用、流程以及如何设置请求头
    BFC的理解
    2016年总结
    如何用shared_ptr减少锁的争用
    webrtc初识
    2015总结与2016展望
    记一次程序排错与std::getline
    spawn协程学习
  • 原文地址:https://www.cnblogs.com/vivider/p/3697661.html
Copyright © 2020-2023  润新知