• 1031 Hello World for U (20 分)


    1. 题目

    Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

    h  d
    e  l
    l  r
    lowo
    

    That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1=n3=max { k | kn2 for all 3≤n2≤N } with n1+n2+n3−2=N.

    Input Specification:

    Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

    Output Specification:

    For each test case, print the input string in the shape of U as specified in the description.

    Sample Input:

    helloworld!
    

    Sample Output:

    h   !
    e   d
    l   l
    lowor
    

    2. 题意

    将一串字符串以U型形式输出出来。

    3. 思路——字符串

    根据题意计算n1,n2,n3,这里n1等于n3,只要定义n1和n2即可。

    计算方法:

    ​ 已知:n1=n3=max {k | k≤n2 for all 3≤n2≤N },且n1+n2+n3-2=N

    ​ 可得:(n1=n3=(N+2)/2)(结果向下取整)

    (n2=N+2-n1-n3)

    计算出n1和n2后,即可根据题目要求输出U型图形(见代码)。

    4. 代码

    #include <iostream>
    #include <string>
    
    using namespace std;
    
    int main()
    {
    	string str;
    	cin >> str;
    	int n1, n2;
    	int N = str.length();
    	n1 = (N + 2) / 3;
    	n2 = N + 2 - (2 * n1);
    	for (int i = 0; i < n1 - 1; ++i)
    	{
    		// 输出第i个字符 
    		cout << str[i];	
    		// 输出中间的空格 
    		for (int j = 0; j < n2 - 2; ++j) cout << " ";
    		// 输出倒数第i+1个字符 
    		cout << str[N - 1 - i] << endl;	
    	}
    	// 最后一行输出剩下的中间字符串 
    	cout << str.substr(n1 - 1, n2) << endl;
    	return 0;
    }
     
    

  • 相关阅读:
    git 学习
    公司领导写给新员工的信
    PLSQl远程连接oracle数据库
    hdu2222之AC自动机入门
    代码中添加事务控制 VS(数据库存储过程+事务) 保证数据的完整性与一致性
    ubuntu13.04安装SenchaArchitect-2.2无法启动的问题
    MVVMLight Toolkit在Windows Phone中的使用扩展之一:在ViewModel中实现导航,并传递参数
    面试题24:二叉搜索树与双向链表
    Struts2中的包的作用描述
    filter-mapping中的dispatcher使用
  • 原文地址:https://www.cnblogs.com/vanishzeng/p/15484819.html
Copyright © 2020-2023  润新知