• 洛谷 P2970 [USACO09DEC]自私的放牧Selfish Grazing


             洛谷 P2970 [USACO09DEC]自私的放牧Selfish Grazing

    题目描述

    Each of Farmer John's N (1 <= N <= 50,000) cows likes to graze in a certain part of the pasture, which can be thought of as a large one-dimeensional number line. Cow i's favorite grazing range starts at location S_i and ends at location E_i (1 <= S_i < E_i; S_i < E_i <= 100,000,000).

    Most folks know the cows are quite selfish; no cow wants to share any of its grazing area with another. Thus, two cows i and j can only graze at the same time if either S_i >= E_j or E_i <= S_j. FJ would like to know the maximum number of cows that can graze at the same time for a given set of cows and their preferences.

    Consider a set of 5 cows with ranges shown below:

      ... 1    2    3    4    5    6    7    8    9   10   11   12   13 ...
      ... |----|----|----|----|----|----|----|----|----|----|----|----|----
    Cow 1:      <===:===>          :              :              :
    Cow 2: <========:==============:==============:=============>:
    Cow 3:          :     <====>   :              :              :
    Cow 4:          :              :     <========:===>          :
    Cow 5:          :              :     <==>     :              :

    These ranges represent (2, 4), (1, 12), (4, 5), (7, 10), and (7, 8), respectively.

    For a solution, the first, third, and fourth (or fifth) cows can all graze at the same time. If the second cow grazed, no other cows could graze. Also, the fourth and fifth cows cannot graze together, so it is impossible for four or more cows to graze.

    约翰有N(1≤N≤50000)头牛,约翰的草地可以认为是一条直线.每只牛只喜欢在某个特定的范围内吃草.第i头牛喜欢在区间(Si,Ei)吃草,1≤Si<Ei≤1,000,000,00.

    奶牛们都很自私,他们不喜欢和其他奶牛共享自己喜欢吃草的领域,因此约翰要保证任意

    两头牛都不会共享他们喜欢吃草昀领域.如果奶牛i和奶牛J想要同时吃草,那么要满足:Si>=Ej或者Ei≤Sj.约翰想知道在同一时刻,最多可以有多少头奶牛同时吃草?

    输入输出格式

    输入格式:

     

    * Line 1: A single integer: N

    * Lines 2..N+1: Line i+1 contains the two space-separated integers: S_i and E_i

     

    输出格式:

     

    * Line 1: A single integer representing the maximum number of cows that can graze at once.

     

    输入输出样例

    输入样例#1: 复制
    5 
    2 4 
    1 12 
    4 5 
    7 10 
    7 8 
    
    输出样例#1: 复制
    3 

    考察算法:排序、贪心(应该也可以用DP做) 难度:普及/提高-

    思路:首先按照每头牛吃草的时间的右端点升序排列(就是从小到大排),定义一个变量记录最右端,使每一段时间的右端点与其比较
    (线段覆盖的题,学姐讲了n个升级版本后,觉得这个挺简单的)

    注意:记录最多牛头数的变量应从1开始

    色彩好丰富,(*^__^*) 嘻嘻……

    #include<algorithm>
    #include<cstdio>
    using namespace std;
    int n, tot = 1;
    struct nond {
        int l, r;
    }e[50005];
    
    bool cmp(nond x, nond y) {
        return x.r < y.r;
    }
    
    int main() {
        scanf("%d", &n);
        for(int i = 1; i <= n; i++) scanf("%d%d", &e[i].l, &e[i].r);
        sort(e+1, e+n+1, cmp);
        int rr = e[1].r;
        for(int i = 2; i <= n; i++)
            if(e[i].l >= rr) { tot++; rr = e[i].r; }
        printf("%d", tot);
        return 0;
    }
    
    
  • 相关阅读:
    正则中的顺序环视和逆序环视
    LeetCode 第 27 场双周赛
    LeetCode 每日一题 198. 打家劫舍
    LeetCode 每日一题 974. 和可被 K 整除的子数组
    LeetCode 每日一题 287. 寻找重复数
    LeetCode 每日一题 4. 寻找两个正序数组的中位数
    LeetCode 每日一题 146. LRU缓存机制
    LeetCode 每日一题 105. 从前序与中序遍历序列构造二叉树
    [转]多线程的那点儿事
    LeetCode 每日一题 5. 最长回文子串
  • 原文地址:https://www.cnblogs.com/v-vip/p/8627210.html
Copyright © 2020-2023  润新知