• HDU 4762 Cut the Cake(公式)


    Cut the Cake

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 263    Accepted Submission(s): 113


    Problem Description
    MMM got a big big big cake, and invited all her M friends to eat the cake together. Surprisingly one of her friends HZ took some (N) strawberries which MMM likes very much to decorate the cake (of course they also eat strawberries, not just for decoration). HZ is in charge of the decoration, and he thinks that it's not a big deal that he put the strawberries on the cake randomly one by one. After that, MMM would cut the cake into M pieces of sector with equal size and shape (the last one came to the party will have no cake to eat), and choose one piece first. MMM wants to know the probability that she can get all N strawberries, can you help her? As the cake is so big, all strawberries on it could be treat as points.
     
    Input
    First line is the integer T, which means there are T cases.
    For each case, two integers M, N indicate the number of her friends and the number of strawberry.
    (2 < M, N <= 20, T <= 400)
     
    Output
    As the probability could be very small, you should output the probability in the form of a fraction in lowest terms. For each case, output the probability in a single line. Please see the sample for more details.
     
    Sample Input
    2 3 3 3 4
     
    Sample Output
    1/3 4/27
     
    Source
     
    Recommend
    liuyiding
     

     公式为:n/m^(n-1)

    import java.util.Scanner;
    import java.math.BigInteger;
    
    public class Main{
        public static void main(String[] args){
            Scanner cin = new Scanner(System.in);
            int t = cin.nextInt();
            while(t!=0){
                t--;
                BigInteger m = cin.nextBigInteger();
                int n = cin.nextInt();
                BigInteger tmp=BigInteger.valueOf(n);
                BigInteger ans=m.pow(n-1);
                BigInteger x=ans.gcd(tmp);
                System.out.println(tmp.divide(x) + "/" + ans.divide(x));
            }
        }
    }
  • 相关阅读:
    php字符串常用函数
    调试心得总结
    搜索查询简单的网页摘要生成
    OFFICE三线表的制作
    阶段性总结20130613
    url查重bloom过滤器
    Linuxvim常用命令
    不打开文件操作db时,如果遇到和窗体交互,不会提示文档未锁,但同样需要锁定当前文档,代码如下
    样条曲线
    不用遍历得到btr中同一类型的实体 CAD2009 vs2008及以上
  • 原文地址:https://www.cnblogs.com/twodog/p/12135342.html
Copyright © 2020-2023  润新知