• hdoj1272-小希的迷宫


    Problem Description

    上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。

    Input

    输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。
    整个文件以两个-1结尾。

    Output

    对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出”Yes”,否则输出”No”。

    Sample Input

    6 8 5 3 5 2 6 4
    5 6 0 0

    8 1 7 3 6 2 8 9 7 5
    7 4 7 8 7 6 0 0

    3 8 6 8 6 4
    5 3 5 6 5 2 0 0

    -1 -1

    Sample Output

    Yes
    Yes
    No

    思路

           本题其实并不难,运用的是并查集,然后判断是否成环。

    code

    #include <iostream>
    #include <fstream> 
    #include <cstring>
    #include <algorithm>
    using namespace std;
    
    int father[100050];
    bool vis[100050];
    
    void init()
    {
        for(int i = 0; i <= 100050; i ++)
        {
            father[i] = i;
            //vis[i] = false;
        }
    }
    
    int find(int x)
    {
        if(father[x] != x)
        {
            father[x] = find(father[x]);
        }
        return father[x];
    }
    
    bool unit(int x, int y)
    {
        int x0 = find(x);
        int y0 = find(y);
    
        if(x0 == y0)
        {
            return false;
        }
    
        father[y0] = x0;
        return true;
    }
    
    int main()
    {
        //ifstream cin("data.in");
        int a, b;
        while(cin >> a >> b && (a != -1 || b != -1))//判断条件一定要写好,因为这WA了好多次
        {
            init();
            int x = a, y = b;
            bool ok = true;
            int cnt = 0;
            memset(vis, false, sizeof(vis));
            //vis[0] = true;
            int m = 0;
            while(1)
            {
                if(x == 0 && y == 0)
                {
                    break;
                }
                if(!unit(x, y) && x != y)
                {
                    ok = false; //当成环时输出NO
                }
                vis[x] = true;
                vis[y] = true;
                cin >> x >> y;
            }
    
            for(int i = 1; i < 100050; ++ i)
            {
                if(vis[i] && find(i) == i)
                {
                    cnt ++;  //判断是否存在多个集合
                }
            }
    
            if((ok && cnt < 2))
            {
                cout << "Yes" << endl;
            } 
            else
            {
                cout << "No" << endl;
            }
        }
        return 0;
    }
  • 相关阅读:
    tsc errors All In One
    TypeScript declare Set Array type All In One
    Linux exit nano editor All In One
    Linux bash pbcopy command All In One
    千焦与千卡的换算公式 All In One
    linux 中 sed N选项将两行合并为一行处理
    linux 中 sed n选项将两行作为一行处理,屏蔽第一行
    linux 中sed命令删除匹配字符之前的一行
    linux 中sed命令 P和p的区别
    linux 中 sed命令替换命令时i选项忽略大小写
  • 原文地址:https://www.cnblogs.com/topk/p/6580096.html
Copyright © 2020-2023  润新知