• 1022 Digital Library (30分)


    A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (≤10
    ​4
    ​​ ) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

    Line #1: the 7-digit ID number;
    Line #2: the book title -- a string of no more than 80 characters;
    Line #3: the author -- a string of no more than 80 characters;
    Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
    Line #5: the publisher -- a string of no more than 80 characters;
    Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].
    It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

    After the book information, there is a line containing a positive integer M (≤1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

    1: a book title
    2: name of an author
    3: a key word
    4: name of a publisher
    5: a 4-digit number representing the year
    Output Specification:

    For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print Not Found instead.

    Sample Input:

    3
    1111111
    The Testing Book
    Yue Chen
    test code debug sort keywords
    ZUCS Print
    2011
    3333333
    Another Testing Book
    Yue Chen
    test code sort keywords
    ZUCS Print2
    2012
    2222222
    The Testing Book
    CYLL
    keywords debug book
    ZUCS Print2
    2011
    6
    1: The Testing Book
    2: Yue Chen
    3: keywords
    4: ZUCS Print
    5: 2011
    3: blablabla
    Sample Output:

    1: The Testing Book
    1111111
    2222222
    2: Yue Chen
    1111111
    3333333
    3: keywords
    1111111
    2222222
    3333333
    4: ZUCS Print
    1111111
    5: 2011
    1111111
    2222222
    3: blablabla
    Not Found

    思路

    模拟题,练习输入输出,注意书名和关键字有重叠的情况,用set去重,另外输出需要设置宽度为7.

    #include<iostream>
    #include<unordered_map>
    #include<string>
    #include<set>
    
    using namespace std;
    
    const int N = 100010;
    
    unordered_map<string, int> h;
    
    int e[N], ne[N], idx = 1;
    
    void add(string &key, int id){
        e[idx] = id, ne[idx] = h[key], h[key] = idx ++;
    }
    
    int main(){
        int n;
        cin >> n;
        
        while(n --){
            int id;
            string title, author, pub, key, year;
            
            cin >> id;
            getchar();
            
            getline(cin, title);
            getline(cin, author);
            
            while(cin >> key, add(key, id), getchar() != '\n');
            
            getline(cin, pub);
            cin >> year;
            add(pub, id), add(year, id), add(title, id), add(author, id);
        }
        
        int m;
        cin >> m;
        getchar();
        
        while(m --){
            char c = getchar();
            getchar(), getchar();
            string query;
            getline(cin, query);
            
            cout << c << ": " << query << endl;
            
            if(h[query] == 0){
                puts("Not Found");
                continue;
            }
            
            set<int> res;
            
            for(int j = h[query]; j; j = ne[j]) res.insert(e[j]);
            
            for(auto t : res) printf("%07d\n", t);   
        }
        
        return 0;
    }
    
  • 相关阅读:
    MySql数据基础之数据表操作
    MySql数据库之数据库基础命令
    MySql数据库基础之数据库简介及安装
    JQuery之Ajax基础
    Ajax简单应用之个人简历页面搭建
    Ajax之处理不同格式的JSON数据
    题解 P2447 【[SDOI2010]外星千足虫】
    题解 P4035 【[JSOI2008]球形空间产生器】
    题解 P2831 【愤怒的小鸟】
    题解 P2827 【蚯蚓】
  • 原文地址:https://www.cnblogs.com/tomori/p/13423507.html
Copyright © 2020-2023  润新知