• [ACM] POJ 1611 The Suspects (并查集,输出第i个人所在集合的总人数)


    The Suspects
    Time Limit: 1000MS   Memory Limit: 20000K
    Total Submissions: 21586   Accepted: 10456

    Description

    Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
    In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
    Once a member in a group is a suspect, all members in the group are suspects. 
    However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

    Input

    The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
    A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

    Output

    For each case, output the number of suspects in one line.

    Sample Input

    100 4
    2 1 2
    5 10 13 11 12 14
    2 0 1
    2 99 2
    200 2
    1 5
    5 1 2 3 4 5
    1 0
    0 0

    Sample Output

    4
    1
    1

    Source


    题意:


    题意直接从YM那里复制过来的。

    http://www.cnblogs.com/yym2013/p/3845448.html

    parent[i] 表示 i号节点的根节点是谁。sum[i] 表示以i号节点为根节点的总节点个数,那么sum[0]即为所求。

    在合并的时候须要略微处理一下。假设find(x)  fin(y)有一个为0时,始终把0作为根节点,也就是说,第0个节点始终在自己的集合中。

    这样最后直接输出sum[0]就能够了。

    代码:

    #include <iostream>
    using namespace std;
    const int maxn=30010;
    int parent[maxn];
    int sum[maxn];
    int st[maxn];
    
    void init(int n)
    {
        for(int i=0;i<n;i++)
        {
            parent[i]=i;
            sum[i]=1;
        }
    }
    
    int find(int x)
    {
        return parent[x]==x?

    x:find(parent[x]); } void unite(int x,int y) { int t1=find(x); int t2=find(y); if(t1==t2) return ; if(t1==0)//始终连接到根为0的节点上 { parent[t2]=t1; sum[t1]+=sum[t2]; } else if(t2==0) { parent[t1]=t2; sum[t2]+=sum[t1]; } else //假设二者的根不为0 ,那就随便了。

    { parent[t1]=t2; sum[t2]+=sum[t1]; } } int main() { int n,m; while(cin>>n>>m&&(n||m)) { init(n); int k;//每组多少个数 while(m--) { cin>>k; cin>>st[0];//就算0个团体0个人,也要输入第一个人。汗 k--; for(int i=1;i<=k;i++) { cin>>st[i]; unite(st[i],st[i-1]); } } cout<<sum[0]<<endl; } return 0; }




  • 相关阅读:
    Linux+postfix+extmail+dovecot打造基于web页面的邮件系统
    各种大型网站技术架构--摘抄
    会php不回缓存行吗?多重实现
    Nutch相关框架视频教程--说明
    Nginx 配置文件模板
    原创:CentOS6.4配置solr 4.7.2+IK分词器
    nutch2.2.1安装部署
    Android View绘制13问13答
    使用 MailOtto 做完美预加载
    ActiveAndroid:活性记录的风格ORM(对象关系映射)
  • 原文地址:https://www.cnblogs.com/tlnshuju/p/7400362.html
Copyright © 2020-2023  润新知