• hdu 5443 The Water Problem(长春网络赛——暴力)


    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5443

    The Water Problem

    Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
    Total Submission(s): 1084    Accepted Submission(s): 863


    Problem Description
    In Land waterless, water is a very limited resource. People always fight for the biggest source of water. Given a sequence of water sources with a1,a2,a3,...,anrepresenting the size of the water source. Given a set of queries each containing 2 integers l and r, please find out the biggest water source between al and ar.
     

    Input
    First you are given an integer T(T10) indicating the number of test cases. For each test case, there is a number n(0n1000) on a line representing the number of water sources. n integers follow, respectively a1,a2,a3,...,an, and each integer is in {1,...,106}. On the next line, there is a number q(0q1000) representing the number of queries. After that, there will be q lines with two integers l and r(1lrn) indicating the range of which you should find out the biggest water source.
     

    Output
    For each query, output an integer representing the size of the biggest water source.
     

    Sample Input
    3 1 100 1 1 1 5 1 2 3 4 5 5 1 2 1 3 2 4 3 4 3 5 3 1 999999 1 4 1 1 1 2 2 3 3 3
     

    Sample Output
    100 2 3 4 4 5 1 999999 999999 1
     

    Source
     

    Recommend
    hujie   |   We have carefully selected several similar problems for you:  5664 5663 5662 5661 5660 
     

    题目大意:给出n个水池的水量,找出区间内最大的水量。

    求区间最值。正常都採用线段树的方法。可是这题数据量不大。全部暴力就过了~

    详见代码。

    #include <iostream>
    #include <cstdio>
    
    using namespace std;
    
    int main()
    {
        int t;
        int a[1010],l,r;
        scanf("%d",&t);
        while (t--)
        {
            int n;
            scanf("%d",&n);
            for (int i=1; i<=n; i++)
            {
                scanf("%d",&a[i]);
            }
            int q;
            scanf("%d",&q);
            while (q--)
            {
                int Max=0;
                scanf("%d%d",&l,&r);
                for (int i=l; i<=r; i++)
                {
                    if (a[i]>Max)
                        Max=a[i];
                }
                cout<<Max<<endl;
            }
        }
        return 0;
    }


  • 相关阅读:
    为什么要用MarkDown?
    Android Studio: Application Installation Failed
    git查看某个文件修改历史
    有些事现在不做,一辈子都不会做了
    onMouseOver&onMouseOut vs onMouseEnter&onMouseLeave
    versionCode & versionName
    display:none vs visibility:hidden
    polyfill
    combineReducers
    React Context
  • 原文地址:https://www.cnblogs.com/tlnshuju/p/7290074.html
Copyright © 2020-2023  润新知