• 线段树+扫描线


    求面积

     参考:https://blog.csdn.net/u013480600/article/details/22548393

    hdu   1542
    
    
    Atlantis
    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 21727    Accepted Submission(s): 8613
    
    
    Problem Description
    There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.
     
    
    Input
    The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1<x2<=100000;0<=y1<y2<=100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.
    
    The input file is terminated by a line containing a single 0. Don’t process it.
     
    
    Output
    For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.
    
    Output a blank line after each test case.
     
    
    Sample Input
    2
    10 10 20 20
    15 15 25 25.5
    0
     
    
    Sample Output
    Test case #1
    Total explored area: 180.00 
     
    
    Source
    Mid-Central European Regional Contest 2000
    #include<iostream>
    #include<cstdio>
    #include<cstdlib>
    #include<cstring>
    #include<string>
    #include<queue>
    #include<algorithm>
    #include<map>
    #include<iomanip>
    #define INF 99999999
    using namespace std;
     
    const int MAX=200+10;
    int mark[MAX<<2];//记录某个区间的下底边个数
    double sum[MAX<<2];//记录某个区间的下底边总长度
    double has[MAX];//对x进行离散化,否则x为浮点数且很大无法进行线段树 
     
    //以横坐标作为线段(区间),对横坐标线段进行扫描
    //扫描的作用是每次更新下底边总长度和下底边个数,增加新面积 
    struct seg{//线段 
        double l,r,h;
        int d;
        seg(){}
        seg(double x1,double x2,double H,int c):l(x1),r(x2),h(H),d(c){}
        bool operator<(const seg &a)const{
            return h<a.h;
        }
    }s[MAX];
     
    void Upfather(int n,int left,int right){
        if(mark[n])sum[n]=has[right+1]-has[left];//表示该区间整个线段长度可以作为底边 
        else if(left == right)sum[n]=0;//叶子结点则底边长度为0(区间内线段长度为0) 
        else sum[n]=sum[n<<1]+sum[n<<1|1];
    }
     
    void Update(int L,int R,int d,int n,int left,int right){
        if(L<=left && right<=R){//该区间是当前扫描线段的一部分,则该区间下底边总长以及上下底边个数差更新 
            mark[n]+=d;//更新底边相差差个数 
            Upfather(n,left,right);//更新底边长 
            return;
        }
        int mid=left+right>>1;
        if(L<=mid)Update(L,R,d,n<<1,left,mid);
        if(R>mid)Update(L,R,d,n<<1|1,mid+1,right);
        Upfather(n,left,right);
    }
     
    int search(double key,double* x,int n){
        int left=0,right=n-1;
        while(left<=right){
            int mid=left+right>>1;
            if(x[mid] == key)return mid;
            if(x[mid]>key)right=mid-1;
            else left=mid+1;
        }
        return -1;
    }
     
    int main(){
        int n,num=0;
        double x1,x2,y1,y2;
        while(cin>>n,n){
            int k=0;
            for(int i=0;i<n;++i){
                cin>>x1>>y1>>x2>>y2;
                has[k]=x1;
                s[k++]=seg(x1,x2,y1,1);
                has[k]=x2;
                s[k++]=seg(x1,x2,y2,-1);
            }
            sort(has,has+k);
            sort(s,s+k);
            int m=1;
            for(int i=1;i<k;++i)//去重复端点 
                if(has[i] != has[i-1])has[m++]=has[i];
            double ans=0;
            //memset(mark,0,sizeof mark);
            //memset(sum,0,sizeof sum);如果下面是i<k-1则要初始化,因为如果对第k-1条线段扫描时会使得mark,sum为0才不用初始化的 
            for(int i=0;i<k;++i){//扫描线段 
                int L=search(s[i].l,has,m);
                int R=search(s[i].r,has,m)-1;
                Update(L,R,s[i].d,1,0,m-1);//扫描线段时更新底边长度和底边相差个数
                ans+=sum[1]*(s[i+1].h-s[i].h);//新增加面积 
            }
            printf("Test case #%d
    Total explored area: %.2lf
    
    ",++num,ans);
        }
        return 0;
    }
  • 相关阅读:
    MySQL主从复制集群添加slave节点
    GTID主从 与 传统主从复制
    20201207总结
    202011051 每周例行报告
    202011121 每周例行报告
    202010081 每周例行报告
    202011261 每周例行报告
    202010153 每周例行报告
    202010291 每周例行报告
    202011201 每周例行报告
  • 原文地址:https://www.cnblogs.com/tingtin/p/10849072.html
Copyright © 2020-2023  润新知