• HDU1200 POJ2039 ZOJ2208 UVALive3084 To and Fro【密码】


    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 9285   Accepted: 6261

    Description

    Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is "There’s no place like home on a snowy night" and there are five columns, Mo would write down 
    t o i o y
    
    h p k n n
    
    e l e a i
    
    r a h s g
    
    e c o n h
    
    s e m o t
    
    n l e w x

    Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character "x" to pad the message out to make a rectangle, although he could have used any letter. 

    Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as 

    toioynnkpheleaigshareconhtomesnlewx 

    Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one. 

    Input

    There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2. . . 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.

    Output

    Each input set should generate one line of output, giving the original plaintext message, with no spaces.

    Sample Input

    5
    toioynnkpheleaigshareconhtomesnlewx
    3
    ttyohhieneesiaabss
    0

    Sample Output

    theresnoplacelikehomeonasnowynightx
    thisistheeasyoneab

    Source



    Regionals 2004 >> North America - East Central NA


    问题链接HDU1200 POJ2039 ZOJ2208 UVALive3084 To and Fro

    问题简述:(略)

    问题分析

    虽然字符串是放在一维数组里,也可以按二维数组的形式对其进行访问,是一个下标映射的问题。

    此外,还需要考虑行的奇偶和行中的顺序访问(奇数行顺序访问)与逆序访问(偶数行逆序访问)。

    程序说明:(略)


    AC的C语言程序(代码中有C++的注释,需要用C++编译)如下:

    /* HDU1200 POJ2039 ZOJ2208 UVALive3084 To and Fro */
    
    #include <stdio.h>
    #include <string.h>
    
    int main(void)
    {
        int c, r, oddeven, len, i, j;
        char s[200+1];
    
        while(scanf("%d", &c) != EOF) {
            if(c == 0)
                break;
    
            scanf("%s", s);
    
            len = strlen(s);
            r = len / c;
            for(j=0; j<c; j++) {        // 行循环
                oddeven = 0;
                for(i=0; i<r; i++) {    // 列循环
                    if(oddeven)
                        // 奇数行:逆序
                        putchar(s[i*c+(c-1-j)]);
                    else
                        // 偶数行:顺序
                        putchar(s[i*c+j]);
                    oddeven = 1 - oddeven;
                }
            }
            putchar('
    ');
        }
    
        return 0;
    }



  • 相关阅读:
    BLE编程中关键步骤
    gradle相关配置内容解析
    Gradle版本变更的问题
    【问题】AndroidStudio导入项目一直卡在Building gradle project infod的最快速解决方案
    jdbc.properties各种数据库连接配置
    EL表达式语言总结
    Android sdk目录介绍
    chrome的常用快捷键和命令
    Unity Hub for Mac 破解
    MAC下安装配置Tomcat
  • 原文地址:https://www.cnblogs.com/tigerisland/p/7564604.html
Copyright © 2020-2023  润新知