企业网三层架构——BCMSN
网段划分:vlan2 172.16.1.0/25 vlan3 172.16.1.128/25
ISP及其他路由器地址如图。
配置
R1
Current configuration : 1064 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname r1
no ip cef
no ipv6 cef
spanning-tree mode pvst
interface FastEthernet0/0
ip address 12.1.1.1 255.255.255.0
ip nat outside
duplex auto
speed auto
interface FastEthernet0/1
ip address 172.16.0.1 255.255.255.252
ip nat inside
duplex auto
speed auto
interface FastEthernet1/0
ip address 172.16.0.5 255.255.255.252
ip nat inside
duplex auto
speed auto
interface FastEthernet1/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
router eigrp 90
redistribute static
network 172.16.0.0
no auto-summary
!
ip nat inside source list 1 interface FastEthernet0/0 overload
ip nat inside source static tcp 172.16.2.3 80 12.1.1.1 80
ip classless
ip route 0.0.0.0 0.0.0.0 12.1.1.2
!
ip flow-export version 9
!
!
access-list 1 permit 172.16.0.0 0.0.255.255
!
line con 0
!
line aux 0
!
line vty 0 4
login
end
ISP配置
isp#show running-config
Building configuration...
Current configuration : 619 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname isp
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 12.1.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 2.2.2.1 255.255.255.0
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
Multilayer Switch0配置
sw1#SHOW RUnning-config
Building configuration...
Current configuration : 2477 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname sw1
!
!
!
!
!
ip dhcp pool v2
network 172.16.1.0 255.255.255.128
default-router 172.16.1.126
dns-server 114.114.114.114
ip dhcp pool v3
network 172.16.1.128 255.255.255.128
default-router 172.16.1.254
dns-server 114.114.114.114
ip routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree vlan 1-2 priority 24576
spanning-tree vlan 3 priority 28672
!
!
!
!
!
!
interface Port-channel 1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/1
!
interface FastEthernet0/2
switchport trunk native vlan 2
!
interface FastEthernet0/3
switchport trunk native vlan 3
!
interface FastEthernet0/4
no switchport
ip address 172.16.2.1 255.255.255.0
duplex auto
speed auto
standby version 2
standby 1 ip 172.16.2.254
standby 1 priority 101
standby 1 preempt
standby 1 track FastEthernet0/24
no switchport
ip address 172.16.0.2 255.255.255.252
ip summary-address eigrp 90 172.16.0.0 255.255.252.0 5
duplex auto
speed auto
!
interface GigabitEthernet0/1
channel-group 1 mode on
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/2
channel-group 1 mode on
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
ip address 172.16.1.1 255.255.255.128
standby version 2
standby 1 ip 172.16.1.126
standby 1 priority 101
standby 1 preempt
standby 1 track FastEthernet0/24
!
interface Vlan3
ip address 172.16.1.129 255.255.255.128
standby version 2
standby 1 ip 172.16.1.254
standby 1 preempt
standby 1 track FastEthernet0/24
!
router eigrp 90
network 172.16.0.0
no auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
Multilayer Switch1配置
sw2#show running-config
Building configuration...
Current configuration : 2441 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname sw2
!
!
!
!
!
ip dhcp pool v2
network 172.16.1.0 255.255.255.128
default-router 172.16.1.126
dns-server 114.114.114.114
ip dhcp pool v3
network 172.16.1.128 255.255.255.128
default-router 172.16.1.254
dns-server 114.114.114.114
ip routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree vlan 3 priority 24576
spanning-tree vlan 1-2 priority 28672
!
!
!
!
!
!
interface Port-channel 1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/1
!
interface FastEthernet0/2
switchport trunk native vlan 2
!
interface FastEthernet0/3
switchport trunk native vlan 3
!
interface FastEthernet0/4
no switchport
ip address 172.16.2.2 255.255.255.0
duplex auto
speed auto
standby version 2
standby 1 ip
standby 1 preempt
standby 1 track FastEthernet0/24
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
no switchport
ip address 172.16.0.6 255.255.255.252
ip summary-address eigrp 90 172.16.0.0 255.255.252.0 5
duplex auto
speed auto
!
interface GigabitEthernet0/1
channel-group 1 mode on
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/2
channel-group 1 mode on
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
ip address 172.16.1.2 255.255.255.128
standby version 2
standby 1 ip 172.16.1.126
standby 1 preempt
standby 1 track FastEthernet0/24
!
interface Vlan3
ip address 172.16.1.130 255.255.255.128
standby version 2
standby 1 ip 172.16.1.254
standby 1 priority 101
standby 1 preempt
standby 1 track FastEthernet0/24
!
router eigrp 90
network 172.16.0.0
no auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
switch0
sw3#show running-config
Building configuration...
Current configuration : 1258 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname sw3
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/2
switchport access vlan 3
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
switchport mode dynamic desirable
!
interface FastEthernet0/24
switchport mode dynamic desirable
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end
switch 1 switch2 配置与switch0 配置相同。
2960交换机配置
Switch#show running-config
Building configuration...
Current configuration : 1043 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end
2960 (直连isp)
Switch#SHOW RUNning-config
Building configuration...
Current configuration : 1043 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end