• 洛谷P3003 [USACO10DEC]苹果交货Apple Delivery


    P3003 [USACO10DEC]苹果交货Apple Delivery

    题目描述

    Bessie has two crisp red apples to deliver to two of her friends in the herd. Of course, she travels the C (1 <= C <= 200,000)

    cowpaths which are arranged as the usual graph which connects P (1 <= P <= 100,000) pastures conveniently numbered from 1..P: no cowpath leads from a pasture to itself, cowpaths are bidirectional, each cowpath has an associated distance, and, best of all, it is always possible to get from any pasture to any other pasture. Each cowpath connects two differing pastures P1_i (1 <= P1_i <= P) and P2_i (1 <= P2_i <= P) with a distance between them of D_i. The sum of all the distances D_i does not exceed 2,000,000,000.

    What is the minimum total distance Bessie must travel to deliver both apples by starting at pasture PB (1 <= PB <= P) and visiting pastures PA1 (1 <= PA1 <= P) and PA2 (1 <= PA2 <= P) in any order. All three of these pastures are distinct, of course.

    Consider this map of bracketed pasture numbers and cowpaths with distances:

                   3        2       2
               [1]-----[2]------[3]-----[4]
                      /               /
                 7   /4  3           /2
                    /               /
                   [5]-----[6]------[7]
                        1       2

    If Bessie starts at pasture [5] and delivers apples to pastures [1] and [4], her best path is:

    5 -> 6-> 7 -> 4 -> 3 -> 2 -> 1

    with a total distance of 12.

    贝西有两个又香又脆的红苹果要送给她的两个朋友。当然她可以走的C(1<=C<=200000)条“牛路”都被包含在一种常用的图中,包含了P(1<=P<=100000)个牧场,分别被标为1..P。没有“牛路”会从一个牧场又走回它自己。“牛路”是双向的,每条牛路都会被标上一个距离。最重要的是,每个牧场都可以通向另一个牧场。每条牛路都连接着两个不同的牧场P1_i和P2_i(1<=P1_i,p2_i<=P),距离为D_i。所有“牛路”的距离之和不大于2000000000。

    现在,贝西要从牧场PB开始给PA_1和PA_2牧场各送一个苹果(PA_1和PA_2顺序可以调换),那么最短的距离是多少呢?当然,PB、PA_1和PA_2各不相同。

    输入输出格式

    输入格式:
    • Line 1: Line 1 contains five space-separated integers: C, P, PB, PA1, and PA2

    • Lines 2..C+1: Line i+1 describes cowpath i by naming two pastures it connects and the distance between them: P1_i, P2_i, D_i
    输出格式:
    • Line 1: The shortest distance Bessie must travel to deliver both apples

    输入输出样例

    输入样例#1:
    9 7 5 1 4 
    5 1 7 
    6 7 2 
    4 7 2 
    5 6 1 
    5 2 4 
    4 3 2 
    1 2 3 
    3 2 2 
    2 6 3 
    
    输出样例#1:
    12 
    /*
        基本上是个最短路模板题吧。。
        就是求出t1和t2间的最短路a1
        再求min(dis[s][t1],dis[s][t2])
        两者相加即可
        本来以为这题没这么简单,随便一写结果A了
        我用的堆优化Dij
    */
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<queue>
    using namespace std;
    #define maxn 100010
    int n,m,s,t1,t2,dis[maxn],num,head[maxn];
    bool vis[maxn];
    struct node{
        int id,d;
        bool operator < (const node b)const{
            return d>b.d;
        }
    };
    struct Node{
        int to,pre,v;
    }e[200010*2];
    void Insert(int from,int to,int v){
        e[++num].to=to;
        e[num].v=v;
        e[num].pre=head[from];
        head[from]=num;
    }
    void Dij(int st,int tt1,int tt2){
        int flag=0;
        priority_queue<node>q;
        memset(dis,127/3,sizeof(dis));
        memset(vis,0,sizeof(vis));
        dis[st]=0;node now;
        now.id=st;now.d=0;
        q.push(now);
        while(!q.empty()){
            now=q.top();q.pop();
            int u=now.id;
            if(vis[u])continue;
            vis[u]=1;
            if(u==tt1)flag++;
            if(u==tt2)flag++;
            if(flag==2)return;
            for(int i=head[u];i;i=e[i].pre){
                int to=e[i].to;
                if(dis[u]+e[i].v<dis[to]){
                    dis[to]=dis[u]+e[i].v;
                    node nxt;nxt.d=dis[to];nxt.id=to;
                    q.push(nxt);
                }
            }
        }
    }
    int main(){
        //freopen("Cola.txt","r",stdin);
        scanf("%d%d%d%d%d",&m,&n,&s,&t1,&t2);
        int x,y,z;
        for(int i=1;i<=m;i++){
            scanf("%d%d%d",&x,&y,&z);
            Insert(x,y,z);
            Insert(y,x,z);
        }
        int a1,a2=0x7fffffff;
        Dij(s,t1,t2);
        a1=min(dis[t1],dis[t2]);
        Dij(t1,t2,t2);
        a2=min(dis[t2],a2);
        Dij(t2,t1,t1);
        a2=min(dis[t1],a2);
        cout<<a1+a2;
    }
  • 相关阅读:
    spark streaming 入门例子
    ElasticSearch-hadoop saveToEs源码分析
    spark 资源参数调优
    spark 任务运行原理
    spark RDD底层原理
    用实例说明Spark stage划分原理
    Spark任务提交底层原理
    spark shuffle内在原理说明
    iOS 辛格尔顿
    CodeForces 22D Segments 排序水问题
  • 原文地址:https://www.cnblogs.com/thmyl/p/7498891.html
Copyright © 2020-2023  润新知