• POJ 1426 Find The Multiple(kuangbin搜索专题)


     
    Find The Multiple
     
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 42281   Accepted: 17760   Special Judge

    Description

    Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

    Input

    The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

    Output

    For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

    Sample Input

    2
    6
    19
    0

    Sample Output

    10
    100100100100100100
    111111111111111111

    提示:该题意思就是让你找到个只由0和1组成的数并且这个数可以整除n,可以用深搜(DFS)来完成。

       找只由0和1组成的数可以从1开始,递推×10和×10+1,一直到找到该数为止。

    代码实现如下(g++):

    #include <cstdio>
    #define ll long long
    
    using namespace std;
    
    int m;
    int flag;
    
    void DFS(ll num,int k)
    {
        if(k==19)//如果到达19位,就结束
        {
            return ;
        }
        if(flag)//如果找到该数
        {
            return ;
        }
        if(num%m==0)
        {
            flag=1;
            printf("%lld\n",num);
            return ;
        }
        DFS(num*10,k+1);//深搜num*10
        DFS(num*10+1,k+1);//深搜num*10+1
    }
    
    
    int main()
    {
        while(~scanf("%d",&m)&&m)
        {
            flag=0;//不要忘记赋初值
            DFS(1,0);//从1开始搜
        }
        return 0;
    }
  • 相关阅读:
    Microsoft 基准安全分析器(MBSA)
    神奇的C++模版
    Windows下的Memcache安装
    BisonFlex 笔记
    虚函数背后的秘密
    如何切换SecureCRT的帐号
    动态生成JS 实现 .NET 网站广告管理
    fatal error C1853 预编译头文件来自编译器的早期版本 解决方法
    解决 unresolved external symbol 无法解析 _send@16
    linux远程登录
  • 原文地址:https://www.cnblogs.com/syycjh/p/9642895.html
Copyright © 2020-2023  润新知