• soj1564. HOUSING


    1564. HOUSING

    Constraints

    Time Limit: 1 secs, Memory Limit: 32 MB

    Description

     

    For the Youth Olympic Games in Singapore, the administration is considering to house each team in several units with at least 5 people per unit. A team can have from 5 to 100 members, depending on the sport they do. For example, if there are 16 team members, there are 6 ways to distribute the team members into units: (1) one unit with 16 team members; (2) two units with 5 and 11 team members, respectively; (3) two units with 6 and 10 team members, respectively; (4) two units with 7 and 9 team members, respectively; (5) two units with 8 team members each; (6) two units with 5 team members each plus a third unit with 6 team members. This list might become quite lengthy for a large team size.

    In order to see how many choices to distribute the team members there are, the administration would like to have a computer program that computes for a number n the number m(n) of possible ways to distribute the team members into the units allocated, with at least 5 people per unit. Note that equivalent distributions like 5 + 5 + 6, 5 + 6 + 5 and 6 + 5 + 5 are counted only once. So m(16) = 6 (as seen above), m(17) = 7 (namely 17, 5 + 12, 6 + 11, 7 + 10, 8 + 9, 5 + 5 + 7, 5 + 6 + 6) and m(20) = 13.

    The computer program should read the number n and compute m(n).

     

    Input

    The input contains just one number which is the number n as described above, where 5 <= n <= 100.

    Output

    The output consists of a single line with an integer that is the number m(n) as specified above. As n is at most 100, one can estimate that m(n) has at most 7 decimal digits.

    Sample Input

    20
    

    Sample Output

    13

    跟那个换零钱的动态规划差不多,但是这里硬币数是由5——n,因此改一改即可。

    #include <iostream>
    #include <memory.h>
    using namespace std;
    long long f[110];
    int main()
    {
    	int n;
    	while(cin >> n)
    	{
    		memset(f,0,sizeof(f));
    		int i;
    		f[0] = 1;
    		int j;
    		for(i  = 5;i <= n;i++)
    		{
    			for(j = i;j <= n;j++)
    				f[j] += f[j-i];
    		}
    		cout << f[n] << endl;
    	}
    	return 0;
    }
    
  • 相关阅读:
    [日常摸鱼]bzoj1470[noi2002]Savage
    [日常摸鱼][POI2000]病毒-Tire图(AC自动机)+dfs
    [日常摸鱼]luogu3398仓鼠找sugar-树链剖分
    [日常摸鱼]luogu1613跑路
    [日常摸鱼]bzoj4802 欧拉函数-PollardRho大整数分解算法
    [日常摸鱼]bzoj1444 [JSOI2009]有趣的游戏——AC自动机+矩阵
    [日常摸鱼]bzoj1038 [ZJOI2008]瞭望塔-模拟退火/几何
    [日常摸鱼]poj2420 A Star not a Tree?
    [日常摸鱼]字符串相关
    图论-拓扑排序-应用
  • 原文地址:https://www.cnblogs.com/sysu-blackbear/p/3280555.html
Copyright © 2020-2023  润新知