• [YTU]_2439( C++习题 复数类--重载运算符+)


    题目描述

    定义一个复数类Complex,重载运算符“+”,使之能用于复数的加法运算。将运算符函数重载为非成员、非友元的普通函数。编写程序,求两个复数之和。

    输入

    两个复数

    输出

    复数之和

    样例输入

    3 4
    5 -10
    

    样例输出

    (8.00,-6.00i)
    #include <iostream>
    #include <iomanip>
    using namespace std;
    class Complex
    {
    public:
        Complex();
        Complex(double r,double i);
        double get_real();
        double get_imag();
        void display();
    private:
        double real;
        double imag;
    };
    Complex::Complex(){}
    Complex::Complex(double r,double i)
    {
        real=r;
        imag=i;
    }
    double Complex::get_real()
    {
        return real;
    }
    double Complex::get_imag()
    {
        return imag;
    }
    Complex operator + (Complex &c1,Complex &c2)
    {return Complex(c1.get_real()+c2.get_real(),c1.get_imag()+c2.get_imag());
    } 
    void Complex::display()
    {
        cout<<'('<<real<<','<<imag<<"i)"<<endl;
    }
    int main()
    {
        double real,imag;
        cin>>real>>imag;
        Complex c1(real,imag);
        cin>>real>>imag;
        Complex c2(real,imag);
        Complex c3=c1+c2;
        cout<<setiosflags(ios::fixed);
        cout<<setprecision(2);
        c3.display();
        return 0;
    }

  • 相关阅读:
    Flink--Table和DataStream和DataSet的集成
    flink-SQL
    Flink的容错
    Flink--基于mysql的sink和source
    Flink--sink到kafka
    Flink在流处理上常见的Source和sink操作
    【计算机网络】-传输层-传输服务的要素
    【计算机网络】-传输层-传输服务
    文件系统-文件的逻辑结构与存取方法
    文件系统-概念
  • 原文地址:https://www.cnblogs.com/sxy201658506207/p/7586349.html
Copyright © 2020-2023  润新知