• hdu1025 最大上升字串


    Constructing Roads In JGShining's Kingdom

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 22338    Accepted Submission(s): 6348


    Problem Description
    JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

    Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource. 

    With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

    Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II. 

    The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones. 

    But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

    For example, the roads in Figure I are forbidden.



    In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^
     
    Input
    Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.
     
    Output
    For each test case, output the result in the form of sample. 
    You should tell JGShining what's the maximal number of road(s) can be built. 
     
    Sample Input
    2 1 2 2 1 3 1 2 2 3 3 1
     
    Sample Output
    Case 1: My king, at most 1 road can be built. Case 2: My king, at most 2 roads can be built.
    Hint
    Huge input, scanf is recommended.
     
    Author
    JGShining(极光炫影)
     
     
    #include <iostream>
    #include <stdio.h>
    #define N 500003
    using namespace std;
    int road[N];
    int dp[N];
    const int inf = 0x7fffffff;
    int main(){
        int c=1;
        int n;
        while((scanf("%d",&n))!=EOF){
            for(int i=0;i<=n;i++){
                dp[i]=inf;
            }
            for(int i=0;i<n;i++){
                int tmp1,tmp2;
                scanf("%d%d",&tmp1,&tmp2);
                road[tmp1]=tmp2;
            }
            int len=0;
            for(int i=1;i<=n;i++){
                *lower_bound(dp,dp+n,road[i])=road[i];
            }
             len = lower_bound(dp,dp+n,inf)-dp;
            if(len==1)  
            {  
                cout<<"Case "<<c++<<":"<<endl;  
                cout<<"My king, at most 1 road can be built."<<endl;  
            }  
            else  
            {  
                cout<<"Case "<<c++<<":"<<endl;  
                cout<<"My king, at most "<<len<<" roads can be built."<<endl;  
            }  
            cout<<endl;  
        }
        return 0;
    }
    View Code

    用STL lower_bound简便到计算出dp序列中,大于等于road[i]到最小到指针,然后替换之,这样dp【i】保存的是第i最大的数。

    最后计算dp中非inf到数字到个数,就可以得到road序列中最长递增子序列。

  • 相关阅读:
    Oracle Index 索引监控
    Oracle Job
    Oracle 数据类型
    Greenplum 的发展历史
    Mongodb账户管理
    MongoDB 备份与恢复
    MySQL 查看用户授予的权限
    Linux 不同方法查看进程消耗CPU IO 等
    Oracle 体系结构图
    Oracle 后台进程(六)PMON进程
  • 原文地址:https://www.cnblogs.com/superxuezhazha/p/5673454.html
Copyright © 2020-2023  润新知