• hdu 1004 Let the Balloon Rise


    Let the Balloon Rise

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 102616    Accepted Submission(s): 39372


    Problem Description
    Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

    This year, they decide to leave this lovely job to you. 
     
    Input
    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

    A test case with N = 0 terminates the input and this test case is not to be processed.
     
    Output
    For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
     
    Sample Input
    5 green red blue red red 3 pink orange pink 0
     
    Sample Output
    red pink
     
    Author
    WU, Jiazhi
     
    Source
     
    #include<stdio.h>
    #include<iostream>
    #include<map>
    using namespace std;
    map<string,int>m;
    int main()
    {
        int n;
        while(~scanf("%d",&n)&&n!=0)
        {
            m.clear();
            string a;
            for(int i=0;i<n;i++)
            {
                cin>>a;
                if(m.count(a))
                {
                    m[a]++;
                }
                else
                    m.insert(pair<string,int>(a,1));
            }
            int maxx=-100;
            string ans;
            map<string,int>::iterator iter;
            for(iter=m.begin(); iter!=m.end(); iter++)
            {
                if(maxx<iter->second)
                    {ans=iter->first;
                    maxx=iter->second;
                    }
            }
            cout<<ans<<endl;
        }
        return 0;
    }
    View Code
     
  • 相关阅读:
    【Spring学习随笔】1. Spring的体系结构
    MySQL图形化安装相关总结(含软件分享)
    Spring Bean 基于注解的装配
    vue的三种图片引入方式
    wx.navigateTo({ url: '', }) 跳转无效问题
    JDK环境变量配置
    如何实现Vue底部按钮点击加载更多
    Java Web学习路线
    百度地图循环添加标注,并循环为鼠标悬停标注时信息窗口问题解决
    mvc jquery 修改 viewbag
  • 原文地址:https://www.cnblogs.com/superxuezhazha/p/5460928.html
Copyright © 2020-2023  润新知