• uva 489 Hangman Judge


    Hangman Judge
    Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu
    Appoint description: 

    Description

    Download as PDF
     

    In ``Hangman Judge,'' you are to write a program that judges a series of Hangman games. For each game, the answer to the puzzle is given as well as the guesses. Rules are the same as the classic game of hangman, and are given as follows:

    1. The contestant tries to solve to puzzle by guessing one letter at a time.
    2. Every time a guess is correct, all the characters in the word that match the guess will be ``turned over.'' For example, if your guess is ``o'' and the word is ``book'', then both ``o''s in the solution will be counted as ``solved.''
    3. Every time a wrong guess is made, a stroke will be added to the drawing of a hangman, which needs 7 strokes to complete. Each unique wrong guess only counts against the contestant once.
         ______   
         |  |     
         |  O     
         | /|    
         |  |     
         | /     
       __|_       
       |   |______
       |_________|
    4. If the drawing of the hangman is completed before the contestant has successfully guessed all the characters of the word, the contestant loses.
    5. If the contestant has guessed all the characters of the word before the drawing is complete, the contestant wins the game.
    6. If the contestant does not guess enough letters to either win or lose, the contestant chickens out.

    Your task as the ``Hangman Judge'' is to determine, for each game, whether the contestant wins, loses, or fails to finish a game.

    Input

    Your program will be given a series of inputs regarding the status of a game. All input will be in lower case. The first line of each section will contain a number to indicate which round of the game is being played; the next line will be the solution to the puzzle; the last line is a sequence of the guesses made by the contestant. A round number of -1 would indicate the end of all games (and input).

    Output

    The output of your program is to indicate which round of the game the contestant is currently playing as well as the result of the game. There are three possible results:

    You win.
    You lose.
    You chickened out.

    Sample Input

    1
    cheese
    chese
    2
    cheese
    abcdefg
    3
    cheese
    abcdefgij
    -1

    Sample Output

    Round 1
    You win.
    Round 2
    You chickened out.
    Round 3
    You lose.
    #include<bits/stdc++.h>
    using namespace std;
    int main()
    {
        int n;
        while(cin>>n)
        {
            if(n==-1)break;
            char puz[1050];
            char gus[1050];
            int did[27];
            scanf("%s",puz);//getchar();
            scanf("%s",gus);//getchar();
            //cout<<puz<<endl;
            //cout<<gus<<endl;
            int flag[1050];
            int stok=0;
            int right=0;
            memset(flag,0,sizeof(flag));
            memset(did,0,sizeof(did));
            //cout<<flag[2]<<endl;
            int findc=0;
            for(int i=0;i<strlen(gus);i++)
            {
                if(stok>6) break;
                findc=0;
                for(int j=0;j<strlen(puz);j++)
                {
                    if(gus[i]==puz[j]&&flag[j]==0)
                    {
                        flag[j]=1;
                        right++;
                        findc=1;
                    }
                }
                if(!findc) { if(!did[gus[i]-'a']) stok++; did[gus[i]-'a']=1;}
            if(stok<7&&right==strlen(puz)) {cout<<"Round "<<n<<endl<<"You win."<<endl;break;}
            }
            if(stok<7&&right<strlen(puz)) cout<<"Round "<<n<<endl<<"You chickened out."<<endl;
            if(stok>6) cout<<"Round "<<n<<endl<<"You lose."<<endl;
           // cout<<right<<endl<<strlen(puz)<<endl;
    
        }
        return 0;
    }

    考虑到多种情况:输入前n项已经匹配了,剩余7+m没有匹配,所以要提前结束。

  • 相关阅读:
    静态(static)代码块、构造代码块、构造函数、父类子类执行顺序
    Java基本特征
    下列哪项不属于jdk1.6垃圾收集器?
    Model-View-Controller(MVC) is an architectural pattern that frequently used in web applications. Which of the following statement(s) is(are) correct?
    ServletConfig对象详解
    ServletConfig接口默认是哪里实现的?
    eclipse根据父类打开子类快捷键
    IDE:Eclipse查看Servlet源码
    IDE:Eclipse查看接口实现类快捷键
    Qt探索之路——多线程实现方法
  • 原文地址:https://www.cnblogs.com/superxuezhazha/p/5295585.html
Copyright © 2020-2023  润新知