• HDU 4727 The Number Off of FFF


    The Number Off of FFF

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 602 Accepted Submission(s): 284


    Problem Description
    X soldiers from the famous " *FFF* army" is standing in a line, from left to right.
    You, as the captain of *FFF*, decides to have a "number off", that is, each soldier, from left to right, calls out a number. The first soldier should call "One", each other soldier should call the number next to the number called out by the soldier on his left side. If every soldier has done it right, they will call out the numbers from 1 to X, one by one, from left to right.
    Now we have a continuous part from the original line. There are N soldiers in the part. So in another word, we have the soldiers whose id are between A and A+N-1 (1 <= A <= A+N-1 <= X). However, we don't know the exactly value of A, but we are sure the soldiers stands continuously in the original line, from left to right.
    We are sure among those N soldiers, exactly one soldier has made a mistake. Your task is to find that soldier.
     
    Input
    The rst line has a number T (T <= 10) , indicating the number of test cases.
    For each test case there are two lines. First line has the number N, and the second line has N numbers, as described above. (3 <= N <= 10 5)
    It guaranteed that there is exactly one soldier who has made the mistake.
     
    Output
    For test case X, output in the form of "Case #X: L", L here means the position of soldier among the N soldiers counted from left to right based on 1.
     
    Sample Input
    2 3 1 2 4 3 1001 1002 1004
     
    Sample Output
    Case #1: 3 Case #2: 3
     
    Source
     


     

    import java.io.*;
    import java.math.BigInteger;
    import java.util.*;
    public class Main {
    	int t,n;
    	long[] a;
    	public static void main(String[] args) throws IOException{
    		new Main().work();
    	}
    	void work() throws IOException{
    		BufferedReader bu=new BufferedReader(new InputStreamReader(System.in));
    		PrintWriter pw=new PrintWriter(new OutputStreamWriter(System.out),true);
    		t=Integer.parseInt(bu.readLine());
    		
    		for(int p=1;p<=t;p++){
    			pw.print("Case #"+p+": ");
    			n=Integer.parseInt(bu.readLine());
    			a=new long[n];
    			String str[]=bu.readLine().split(" "); 
    			for(int i=0;i<n;i++){
    				a[i]=Long.parseLong(str[i]);
    			}
    			
    			long i=a[0];
    			boolean boo=true;
    			
    			for(int j=0;j<n;j++,i++){
    				if(i!=a[j]){
    					pw.println(j+1);
    					boo=false;
    					break;
    				}
    			}
    			if(boo)
    				pw.println(1);
    		}
    	}
    }
    


     

  • 相关阅读:
    发邮件
    加密解密帮助类(对称加密)
    枚举静态类
    【06月05日】A股滚动市净率PB历史新低排名
    【06月04日】A股滚动市盈率PE历史新低排名
    【06月03日】预分红股息率最高排名
    北上资金近1周流入排行榜
    最近一月研报推荐次数最多的最热股票
    【2019年05月28日】指数估值排名
    北上资金近1周流入排行榜
  • 原文地址:https://www.cnblogs.com/suncoolcat/p/3325002.html
Copyright © 2020-2023  润新知