• HDU 1010Tempter of the Bone(奇偶剪枝回溯dfs)


    Tempter of the Bone

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 55541    Accepted Submission(s): 14983

    Problem Description
    The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

    The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
     
    Input
    The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

    'X': a block of wall, which the doggie cannot enter; 
    'S': the start point of the doggie; 
    'D': the Door; or
    '.': an empty block.

    The input is terminated with three 0's. This test case is not to be processed.
     
    Output
    For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
     
    Sample Input
    4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
     
    Sample Output
    NO YES
     
    Author
    ZHANG, Zheng
     
    Source
     


           题目大意: 要求每个点只能走一次,从起点走到终点刚好sum步,点表示可以走得路经。S,D分别代表起点终点。

    解题思路:每个点只能走一次,所以必须回溯。开始没想到剪枝,果断TLE了,而且因为yes,no的大小写还WA了一发脑残了。

            题目地址:Tempter of the Bone

    AC代码:
    #include<iostream>
    #include<cstring>
    #include<string>
    #include<cmath>
    #include<cstdio>
    using namespace std;
    char a[10][10];
    int visi[10][10];
    int n,m,sum,flag;
    struct node
    {
        int x;
        int y;
    };
    node sta,en;  //起点与终点
    int dir[4][2]=  //四个方向
    {
        {-1,0},{1,0},{0,-1},{0,1}
    };
    
    void dfs(int cx,int cy,int step)
    {
        int i;
        if(flag==1) return;   //找到解
        if(step==sum)
        {
            if(cx==en.x&&cy==en.y)
               flag=1;
            return;
        }
        int need=abs(cx-en.x)+abs(cy-en.y);
        int tmp=sum-step;
        if((tmp%2==0&&need%2==1)||(need%2==0&&tmp%2==1)||tmp<need)  //奇偶剪枝
           return;
        for(i=0;i<4;i++)
        {
            int px,py;
            px=cx+dir[i][0],py=cy+dir[i][1];
            if(px>=0&&px<n&&py>=0&&py<m&&(a[px][py]=='.'||a[px][py]=='D')&&!visi[px][py])
            {
                visi[px][py]=1;
                dfs(px,py,step+1);
                visi[px][py]=0;  //回溯
            }
        }
        //return;
    }
    
    int main()
    {
        int i,j;
        while(scanf("%d%d%d",&n,&m,&sum))
        {
            if(n==0&&m==0&&sum==0)
                break;
            for(i=0;i<n;i++)
                scanf("%s",a[i]);
            flag=0;
            for(i=0;i<n;i++)  //找起点
            {
                for(j=0;j<m;j++)
                {
                   if(a[i][j]=='S')
                   {
                      sta.x=i; sta.y=j;
                      flag=1; break;
                   }
                }
                if(flag) break;
            }
            flag=0;
            for(i=0;i<n;i++)  //找终点
            {
                for(j=0;j<m;j++)
                {
                   if(a[i][j]=='D')
                   {
                      en.x=i; en.y=j;
                      flag=1; break;
                   }
                }
                if(flag) break;
            }
    
            flag=0;
            memset(visi,0,sizeof(visi));
            visi[sta.x][sta.y]=1;
            dfs(sta.x,sta.y,0);
            if(flag) puts("YES");
            else puts("NO");
        }
        return 0;
    }
    
    //703MS 228K
    


  • 相关阅读:
    5、axios获取后端数据
    token
    转载:requestAnimationFrame
    YII的特殊删除语句组装
    c /c++ 工程写法 linux makefile多文件编译 原理
    c 语言函数传参的sizeof问题
    使用mermaid语言定制甘特图,Typora/语雀都支持
    Nginx 配置文件
    Docker Compose(7)
    Docker网络模式详解及容器间网络通信(6)
  • 原文地址:https://www.cnblogs.com/suncoolcat/p/3313182.html
Copyright © 2020-2023  润新知