• hdu Eddy's picture (最小生成树)


    Eddy's picture

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 29   Accepted Submission(s) : 26

    Font: Times New Roman | Verdana | Georgia

    Font Size: ← →

    Problem Description

    Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
    Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?

    Input

    The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point. 

    Input contains multiple test cases. Process to the end of file.

    Output

    Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points. 

    Sample Input

    3
    1.0 1.0
    2.0 2.0
    2.0 4.0
    

    Sample Output

    3.41
    #include <iostream>
    #include<cstdio>
    #include<cstring>
    #include<cmath>
    #include<climits>
    using namespace std;
    const int maxn=105;
    double mp[maxn][maxn];
    double dis[maxn],x[maxn],y[maxn];
    int vis[maxn];
    int i,j,n,l,k;
    double minn,sum;
    
    int main()
    {
        while(~scanf("%d",&n))
        {
            memset(vis,0,sizeof(vis));
            for(i=1;i<=n;i++) scanf("%lf%lf",&x[i],&y[i]);
            for(i=1;i<=n;i++)
                for(j=i+1;j<=n;j++)
                {
                    double d=sqrt(pow(x[i]-x[j],2)+pow(y[i]-y[j],2));
                    mp[i][j]=d;
                    mp[j][i]=d;
                }
         sum=0;
         vis[1]=1;
         for(i=1;i<=n;i++) dis[i]=mp[1][i];
        for(i=1;i<n;i++)
        {
            minn=INT_MAX*1.0;
            for(j=1;j<=n;j++)
                if(!vis[j] && minn>dis[j])
                {
                    k=j;
                    minn=dis[j];
                }
            vis[k]=1;
            sum+=minn;
            for(j=1;j<=n;j++)
             if (!vis[j] && dis[j]>mp[k][j])
                dis[j]=mp[k][j];
        }
            printf("%.2lf\n",sum);
        }
        return 0;
    }
  • 相关阅读:
    uni-app 苹果内购支付及获取苹果支付成功信息
    nginx强制使用https访问(http跳转到https)
    最新IOS审核被拒原因TOP10 | 附带解决方法
    ethercat PREEMPT SMP
    client-go workqueue
    k8s apiserver 重启失败
    cni flannel iptables -t filter -D FORWARD -j REJECT --reject-with icmp-host-prohibited
    nginx configmap
    golang yaml LoadYAML
    not found: manifest unknown: manifest unknown
  • 原文地址:https://www.cnblogs.com/stepping/p/5723118.html
Copyright © 2020-2023  润新知