• [ACM] hdu You can Solve a Geometry Problem too (线段是否相交及交点个数)


    Problem Description

    Many geometry(几何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the experience of many ACMers, geometry problems are always much trouble, but this problem is very easy, after all we are now attending an exam, not a contest :)
    Give you N (1<=N<=100) segments(线段), please output the number of all intersections(交点). You should count repeatedly if M (M>2) segments intersect at the same point.

    Note:
    You can assume that two segments would not intersect at more than one point.

    Input

    Input contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s ending.
    A test case starting with 0 terminates the input and this test case is not to be processed.

    Output

    For each case, print the number of intersections, and one line one case.

    Sample Input

    2
    0.00 0.00 1.00 1.00
    0.00 1.00 1.00 0.00
    3
    0.00 0.00 1.00 1.00
    0.00 1.00 1.00 0.000
    0.00 0.00 1.00 0.00
    0
    

    Sample Output

    1
    3
    

    Author

    lcy

    模板:

    struct point//构造点
    {
        double x,y;
    };
    struct line//构造线段
    {
        point a,b;
    };
    
    double multi(point p1,point p2,point p0)//矩形面积
    {
        return((p1.x-p0.x)*(p2.y-p0.y)-(p2.x-p0.x)*(p1.y-p0.y));
    }
    
    bool intersect(line u,line v)//判断两线段是否相交
    {
     return( (max(u.a.x,u.b.x)>=min(v.a.x,v.b.x))&&
            (max(v.a.x,v.b.x)>=min(u.a.x,u.b.x))&&
            (max(u.a.y,u.b.y)>=min(v.a.y,v.b.y))&&
            (max(v.a.y,v.b.y)>=min(u.a.y,u.b.y))&&
            (multi(v.a,u.b,u.a)*multi(u.b,v.b,u.a)>=0)&&
            (multi(u.a,v.b,v.a)*multi(v.b,u.b,v.a)>=0));
    }
    


    本题代码:

    #include <iostream>
    #include <algorithm>
    using namespace std;
    
    struct point//构造点
    {
        double x,y;
    };
    struct line//构造线段
    {
        point a,b;
    };
    
    double multi(point p1,point p2,point p0)//矩形面积
    {
        return((p1.x-p0.x)*(p2.y-p0.y)-(p2.x-p0.x)*(p1.y-p0.y));
    }
    
    bool intersect(line u,line v)//判断两线段是否相交
    {
     return( (max(u.a.x,u.b.x)>=min(v.a.x,v.b.x))&&
            (max(v.a.x,v.b.x)>=min(u.a.x,u.b.x))&&
            (max(u.a.y,u.b.y)>=min(v.a.y,v.b.y))&&
            (max(v.a.y,v.b.y)>=min(u.a.y,u.b.y))&&
            (multi(v.a,u.b,u.a)*multi(u.b,v.b,u.a)>=0)&&
            (multi(u.a,v.b,v.a)*multi(v.b,u.b,v.a)>=0));
    }
    line lin[102];
    
    int main()
    {
        int n;
        while(cin>>n&&n)
        {
            for(int i=1;i<=n;i++)
                cin>>lin[i].a.x>>lin[i].a.y>>lin[i].b.x>>lin[i].b.y;
            int count=0;//交点个数
            for(int i=1;i<=n;i++)
                for(int j=i+1;j<=n;j++)
            {
                if(intersect(lin[i],lin[j]))
                    count++;
            }
            cout<<count<<endl;
        }
        return 0;
    }
    

  • 相关阅读:
    如何使用谷歌学术
    联合省选 2021 游记
    生成one-hot的方法
    GraphSAGE
    maven仓库如何引入本地jar包,Maven多种方式打可执行jar包
    DDL任务管理语句
    使用本地EDAS注册多个中台服务,供本地测试使用
    启动轻量级配置及注册中心EDAS
    端口被占用如何解决
    java8中Collectors.groupingBy 用法
  • 原文地址:https://www.cnblogs.com/sr1993/p/3697788.html
Copyright © 2020-2023  润新知