• [ACM] hdu 2844 Coins (多重背包)


    Coins

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 6347    Accepted Submission(s): 2589


    Problem Description
    Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

    You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
     


     

    Input
    The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
     


     

    Output
    For each test case output the answer on a single line.
     


     

    Sample Input
    3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
     


     

    Sample Output
    8 4
     


     

    Source

    解题思路:

    给出一些价值的硬币,每种硬币有一定的数量,给出一个数m,问用这些硬币可以组合成价值1到m中的几个数。

    代码:

    #include <iostream>
    #include <algorithm>
    #include <string.h>
    using namespace std;
    const int maxn=100005;//有多少种物品
    const int inf=0x7fffffff;
    int c[maxn];//每种的价值
    int num[maxn];//每种的数量
    int f[maxn];
    int v;//最大容量
    
    void ZeroOnePack(int cost,int value)
    {
        int i;
        for(i=v;i>=cost;i--)
            f[i]=max(f[i],f[i-cost]+value);
    }
    
    void CompletePack(int cost ,int value)
    {
        int i;
        for(i=cost;i<=v;i++)
            f[i]=max(f[i],f[i-cost]+value);
    }
    
    void MultiPack(int cost ,int value,int amount)
    {
        if(v<=cost*amount)
        {
            CompletePack(cost,value);
            return;
        }
        else
        {
            int k=1;
            while(k<amount)
            {
                ZeroOnePack(k*cost,k*value);
                amount-=k;
                k*=2;
            }
            ZeroOnePack(amount*cost,amount*value);
        }
    }
    int main()
    {
        int n;
        while(cin>>n>>v&&(n||v))
        {
            for(int i=0;i<n;i++) cin>>c[i];
            for(int i=0;i<n;i++) cin>>num[i];
            for(int i=0;i<=v;i++)
                f[i]=-1*inf;
            f[0]=0;
            for(int i=0;i<n;i++)
                MultiPack(c[i],c[i],num[i]);
            int sum=0;
            for(int i=1;i<=v;i++)
            {
                if(f[i]>0)
                    sum++;
            }
            cout<<sum<<endl;
        }
        return 0;
    }
    


     

  • 相关阅读:
    (Problem 14)Longest Collatz sequence
    (Problem 13)Large sum
    (Problem 10)Summation of primes
    (Problem 9)Special Pythagorean triplet
    (Problem 7)10001st prime
    (Problem 6)Sum square difference
    数组
    断点及复习
    抽象和封装
    类和对象
  • 原文地址:https://www.cnblogs.com/sr1993/p/3697757.html
Copyright © 2020-2023  润新知