• hdu 水仙花数


    此题很容易理解,关键是输出格式

     

    水仙花数

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 74382    Accepted Submission(s): 21973


    Problem Description
    春天是鲜花的季节,水仙花就是其中最迷人的代表,数学上有个水仙花数,他是这样定义的:
    “水仙花数”是指一个三位数,它的各位数字的立方和等于其本身,比如:153=1^3+5^3+3^3。
    现在要求输出所有在m和n范围内的水仙花数。
     
    Input
    输入数据有多组,每组占一行,包括两个整数m和n(100<=m<=n<=999)。
     
    Output
    对于每个测试实例,要求输出所有在给定范围内的水仙花数,就是说,输出的水仙花数必须大于等于m,并且小于等于n,如果有多个,则要求从小到大排列在一行内输出,之间用一个空格隔开;
    如果给定的范围内不存在水仙花数,则输出no;
    每个测试实例的输出占一行。
     
    Sample Input
    100 120
    300 380
     
    Sample Output
    no
    370 371
     
    Author
    lcy
     
    Source
    C语言程序设计练习(二
    代码:
    #include "stdio.h"
    int main()
    { int a,b,c,m,n,i,j=0,k=0;
    int s[400]={0};
       while(scanf("%d%d",&m,&n)!=EOF)
         {for(i=m;i<=n;i++)
           {a=i%10;
            b=i/10%10;
            c=i/100;
            if(i==a*a*a+b*b*b+c*c*c)
              {s[j++]=i;
               k++;
              }
            }
            for(i=0;i<j;i++)
             {
              printf("%d ",s[i]);
              }
              if(i==j)                        // 输出格式即让最后一个输出时无空格 且换行
             {printf("%d ",s[i]);
            
             }
              if(k==0)
             {printf("no ");} 
            k=0;
            j=0;
         }
         return 0;
  • 相关阅读:
    objectc 垃圾回收机制
    core date
    core data 中删除一个对象
    cell.accessoryType
    使用core data 框架
    Excel cell format in dynamcis ax 2009
    How to using X++ code to add security checking for go to main table
    Dos命令
    How to fix to report is empty issue
    Hot to catching ClrErrors in Dynamics AX
  • 原文地址:https://www.cnblogs.com/songmingtao/p/3223452.html
Copyright © 2020-2023  润新知