• hdoj2389--Rain on your Parade(二分图HK算法)


     

    Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 655350/165535 K (Java/Others)
    Total Submission(s): 3359    Accepted Submission(s): 1083


    Problem Description
    You’re giving a party in the garden of your villa by the sea. The party is a huge success, and everyone is here. It’s a warm, sunny evening, and a soothing wind sends fresh, salty air from the sea. The evening is progressing just as you had imagined. It could be the perfect end of a beautiful day.
    But nothing ever is perfect. One of your guests works in weather forecasting. He suddenly yells, “I know that breeze! It means its going to rain heavily in just a few minutes!” Your guests all wear their best dresses and really would not like to get wet, hence they stand terrified when hearing the bad news.
    You have prepared a few umbrellas which can protect a few of your guests. The umbrellas are small, and since your guests are all slightly snobbish, no guest will share an umbrella with other guests. The umbrellas are spread across your (gigantic) garden, just like your guests. To complicate matters even more, some of your guests can’t run as fast as the others.
    Can you help your guests so that as many as possible find an umbrella before it starts to pour?

    Given the positions and speeds of all your guests, the positions of the umbrellas, and the time until it starts to rain, find out how many of your guests can at most reach an umbrella. Two guests do not want to share an umbrella, however.
     
    Input
    The input starts with a line containing a single integer, the number of test cases.
    Each test case starts with a line containing the time t in minutes until it will start to rain (1 <=t <= 5). The next line contains the number of guests m (1 <= m <= 3000), followed by m lines containing x- and y-coordinates as well as the speed si in units per minute (1 <= si <= 3000) of the guest as integers, separated by spaces. After the guests, a single line contains n (1 <= n <= 3000), the number of umbrellas, followed by n lines containing the integer coordinates of each umbrella, separated by a space.
    The absolute value of all coordinates is less than 10000.
     
    Output
    For each test case, write a line containing “Scenario #i:”, where i is the number of the test case starting at 1. Then, write a single line that contains the number of guests that can at most reach an umbrella before it starts to rain. Terminate every test case with a blank line.
     
    Sample Input
    2
    1
    2
    1 0 3
    3 0 3
    2
    4 0
    6 0
    1
    2
    1 1 2
    3 3 2
    2
    2 2
    4 4
     
    Sample Output
    Scenario #1:
    2
     
    Scenario #2:
    2
     
    Source
     
    Recommend
    lcy   |   We have carefully selected several similar problems for you:  2393 2390 2388 2391 2386 
     
    Hopcroft-Karp算法(适用于节点数较多的二分图问题)。
    #include <cmath>
    #include <queue> 
    #include <cstdio> 
    #include <cstring>
    #define N 3001 
    const int INF = 0x3f3f3f3f;
    using namespace std;
    int Nx, Ny, dis;
    int Mx[N], My[N], dx[N], dy[N], vis[N], map[N][N];
    struct condit{
        double x, y, V;
    }num[N], Sz[N];
    bool Dfs(int u){
        for(int v = 0; v < Ny; v++)
            if(!vis[v] && map[u][v] && dy[v] == dx[u] + 1){
                vis[v] = 1;
                if(My[v] != -1 && dy[v] == dis)
                    continue;
                if(My[v] == -1|| Dfs(My[v])){
                    My[v] = u;
                    Mx[u] = v;
                    return 1;
                }
            }
        return 0;
    }
    bool Search(){
        queue<int> Q;
        dis = INF;
        memset(dx, -1, sizeof(dx));
        memset(dy, -1, sizeof(dy));
        for(int i = 0; i < Nx; i++)
            if(Mx[i] == -1){
                Q.push(i);
                dx[i] = 0;
            }
        while(!Q.empty()){
            int u = Q.front();
            Q.pop();
            if(dx[u] > dis)
                break;
            for(int v = 0; v < Ny; v++)
                if(map[u][v] && dy[v] == -1){
                    dy[v] = dx[u] + 1;
                    if(My[v] == -1)
                        dis = dy[v];
                    else{
                        dx[My[v]] = dy[v] + 1;
                        Q.push(My[v]); 
                    }
                } 
        }
        return dis != INF;
    }
    int Maxmatch(){
        int res = 0;
        memset(Mx, -1, sizeof(Mx));
        memset(My, -1, sizeof(My));
        while(Search()){
            memset(vis, 0, sizeof(vis));
            for(int i = 0; i < Nx; i++)
                if(Mx[i] == -1&& Dfs(i))
                    res++;
        }
        return res;
    }
    double Count(condit a, condit b){
        double c = a.x - b.x;
        double d = a.y - b.y;
        return sqrt(c*c+d*d);
    }
    int main(){
        int t, Q = 1;
        scanf("%d", &t);
        while(t--){
        //memset(dis, 0, sizeof(dis));
            memset(map, 0, sizeof(map));
            int n, m, Vt;
            scanf("%d", &Vt);
            scanf("%d", &m);
            for(int i = 0; i < m; i++)
                scanf("%lf%lf%lf", &num[i].x, &num[i].y, &num[i].V);
            scanf("%d", &n);
            for(int i = 0; i < n; i++)
                scanf("%lf%lf", &Sz[i].x, &Sz[i].y);
            Nx = m; Ny = n;
            for(int i = 0; i < m; i++)
                for(int j = 0; j < n; j++){
                    if(Count(num[i], Sz[j])/num[i].V <= Vt)
                        map[i][j] = 1;
                }
            printf("Scenario #%d:
    %d
    
    ", Q++, Maxmatch());
        }
        return 0;
    } 
  • 相关阅读:
    Jasper 常用知识点总结
    Linux
    搭建spring项目,无法创建RequestMappingHandlerMapping异常
    pom.xml文件设置
    MySQL的常用JSON函数
    SQL中的条件判断语句(case when zhen if,ifnull)用法
    sql查询原理
    sql积累
    Linux常用命令大全
    mysql中group by 的用法解析
  • 原文地址:https://www.cnblogs.com/soTired/p/5062108.html
Copyright © 2020-2023  润新知