• poj 3050 Hopscotch DFS+暴力搜索+set容器


    Hopscotch
    Time Limit: 1000MS
    Memory Limit: 65536K
    Total Submissions: 2774
    Accepted: 1940

    Description

    The cows play the child's game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes. 

    They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited). 

    With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201). 

    Determine the count of the number of distinct integers that can be created in this manner.

    Input

    * Lines 1..5: The grid, five integers per line

    Output

    * Line 1: The number of distinct integers that can be constructed

    Sample Input

    1 1 1 1 1
    1 1 1 1 1
    1 1 1 1 1
    1 1 1 2 1
    1 1 1 1 1

    Sample Output

    15

    Hint

    OUTPUT DETAILS: 
    111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.
    1.对于上面的每一组数,刚开始是以字符串处理的,,后来看了一下别人的博客,
    才发现直接十进制数的大小不同可以省掉很多麻烦
    2.重点在于set集合的使用,,其有去重功能,,貌似白书上介绍过
    #include <iostream>
    #include<cstdio>
    #include<set>
    #include<cstring>
    using namespace std;
    int a[7][7];
    int dx[4]={0,0,1,-1},dy[4]={1,-1,0,0};
    set<int> q;
    int dfs(int step,int x,int y,int v)
    {
         if(step==6)
             q.insert(v);
         else
                for(int i=0;i<=3;i++)
                {
                     int kx=x+dx[i];
                     int ky=y+dy[i];
                     if(kx>=1&&kx<=5&&ky>=1&&ky<=5)
                       dfs(step+1,kx,ky,v*10+a[kx][ky]);
                }
        return 0;
    }
    int main()
    {
        for(int i=1;i<=5;i++)
            for(int j=1;j<=5;j++)
              scanf("%d",&a[i][j]);
        for(int i=1;i<=5;i++)
            for(int j=1;j<=5;j++)
                 dfs(1,i,j,a[i][j]);
        printf("%d ",q.size());
        return 0;
    }

  • 相关阅读:
    Python学习笔记(三): 收集参数
    Effective Java 之-----关于延迟初始化
    Effective Java 之-----返回零长度的数组或集合而不是null
    CSS学习笔记(一):定位与溢出
    Python学习笔记(二):字典
    Effective Java 之-----静态工厂与构造器
    Effective Java 之-----for-each循环优于传统的for循环
    Python学习笔记(一):列表和元组
    Effective Java 之-----精确的答案与double&float
    Effective Java 之-----消除过期的对象引用
  • 原文地址:https://www.cnblogs.com/smilesundream/p/6642554.html
Copyright © 2020-2023  润新知