• Similar Word 变序词代码


    Similar Word

    description

      It was a crummy day for Lur. He failed to pass to the CET-6 (College English Test Band-6). Looking back on how it was in last year gone by, he gradually noticed he had fled too many English Lessons. But he determines to memorize words on his bed ,not in the classroom. You know, it is not that easy to pass the test mainly because the large amount of born words.

         Lur is intelligent on games , never English. He cann't learn the similar words by heart. He

    always choose to select a word to learn from the similar words . For him, two words are similar if and only if one word can equal to the other by multiple cyclic shift(at least 1). For example, "car" and "arc" are similar words, while "car" and "rca" are also similar words . To save more time to play games,

      Lur want to know wether two words are similar words faster, he asks you to write a program to tell him ,can you help him ?

                                                        

    input

      There are multiple test cases. Each case contains two lines. Each line contains a word,

    W. You can assume that length(W)<=10^5 . Ended by EOF.

                                                        

    output

      Output “yes” in a single line if two words are similar,otherwise you should output  “no” in a single line.

                                                        

    sample_input

    car

    arc

    car

    cra

    car

    car

                                                        

    sample_output

    yes

    no

    no

    #include<iostream>
    #include<cstring>
    #include<algorithm>
    using namespace std;
     
    //Copyright      感谢Coral提供法思路
     
    int main()
    {        chars1[100001], s2[100001], temp[200002];
             int  len,len2, i;
     
             while( cin >> s1 >> s2 )
             {        if ( strcmp ( s1, s2 ) != 0 ) //长的一样可不行
                       {        len = strlen ( s1 ); len2= strlen(s2);
                                {        strcpy ( temp, s1 ); //复制组成循环单词
     
                                         for( i = len; i < 2 * len - 1; i++ )
                                         {        temp[i] = s1[i - len];
                                         }
     
                                         //cout<< temp << endl;
                                         if( strstr ( temp, s2 )&& len==len2 ) //查找是否存在该单词序列strstr不能保证单词构成相同,比如car和ca;
                                                   cout<< "yes" << endl;
     
                                         else
                                                   cout<< "no" << endl;
     
                                }
                       }
     
                       else
                                cout<< "no" << endl;
     
             }
     
     
    }



  • 相关阅读:
    C++ 课程设计——电梯调度系统
    PAT 1006 Sign In and Sign Out 查找元素
    PAT 1005 Spell It Right 字符串处理
    C++ 词汇表
    四六级分数竟是这样算出来的!交白卷都不会得零分 (转)
    以太坊智能合约部署
    如何设计一个通证经济体系?(转载)
    以太坊上那些暴力“利”的应用(转载)
    geth搭建以太坊私链及常用操作
    ubuntu18.04 安装 QQ
  • 原文地址:https://www.cnblogs.com/slankka/p/9158650.html
Copyright © 2020-2023  润新知