• 【HDU


    Oil Deposits

    Descriptions:

    The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 

    Input

    The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 
    Output

    For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets. 
    Sample Input

    1 1

    *

    3 5

    *@*@*

    **@**

    *@*@*

    1 8

    @@****@*

    5 5

    ****@

    *@@*@

    *@**@

    @@@*@

    @@**@

    0 0

    Sample Output

    0

    1

    2

    2

    题目大意:

    GeoSurvComp地质调查公司负责探测地下石油储藏。 GeoSurvComp现在在一块矩形区域探测石油,并把这个大区域分成了很多小块。他们通过专业设备,来分析每个小块中是否蕴藏石油。如果这些蕴藏石油的小方格相邻,那么他们被认为是同一油藏的一部分。在这块矩形区域,可能有很多油藏。你的任务是确定有多少不同的油藏。

    Input

    输入可能有多个矩形区域(即可能有多组测试)。每个矩形区域的起始行包含m和n,表示行和列的数量,1<=n,m<=100,如果m =0表示输入的结束,接下来是n行,每行m个字符。每个字符对应一个小方格,并且要么是'*',代表没有油,要么是'@',表示有油。

    Output

    对于每一个矩形区域,输出油藏的数量。两个小方格是相邻的,当且仅当他们水平或者垂直或者对角线相邻(即8个方向)。

    题目链接:

    https://vjudge.net/problem/HDU-1241

    典型的dfs深搜题,加个染色就行,即每个大油田染上一种颜色,求出多少种颜色即可

    AC代码

    #include <iostream>
    #include <cstdio>
    #include <fstream>
    #include <algorithm>
    #include <cmath>
    #include <deque>
    #include <vector>
    #include <queue>
    #include <string>
    #include <cstring>
    #include <map>
    #include <stack>
    #include <set>
    #define mod 1000000007
    #define ll long long
    #define INF 0x3f3f3f3f
    using namespace std;
    int n,m,num;
    int vis[105][105];//是否能染色
    char mp[105][105];//记录地图
    int dt[8][2]={{0,-1},{0,1},{1,0},{-1,0},{1,-1},{1,1},{-1,-1},{-1,1}};//八个方向
    void dfs(int x,int y)
    {
        if(mp[x][y]=='#'||vis[x][y]!=0||x<0||y<0||x>=n||y>=m)//不满足条件就返回
            return;
        vis[x][y]=num;//染色
        for(int i=0; i<8; i++)//判断往哪走
        {
            int tx=x+dt[i][0];
            int ty=y+dt[i][1];
            if(mp[tx][ty]=='@'&&vis[tx][ty]==0&&tx>=0&&tx<n&&ty>=0&&ty<m)
            {
                dfs(tx,ty);
            }
        }
    }
    int main()
    {
        while(cin >> n>>m,n+m)
        {
            num=0;
            memset(vis,0,sizeof(vis));
            for(int i=0; i<n; i++)
                cin >> mp[i];
            for(int i=0; i<n; i++)
            {
                for(int j=0; j<m; j++)
                {
                    if(mp[i][j]=='@'&&vis[i][j]==0)//搜索满足条件
                    {
                        num++;//这一块染上这个数字的颜色
                        dfs(i,j);//开始深搜
                    }
                }
            }
            cout<< num << endl;//有几种颜色
        }
    }
  • 相关阅读:
    Linux Ubuntu 忘记用户名和密码 解决办法
    C语言中标准输入流、标准输出流、标准错误输出流
    递归实现字符串反转char* reverse(char* str)合集
    (转)最好的求平方根的方法(精确度VS速度)Best Square Root Method Algorithm Function (Precision VS Speed)
    java验证码识别4
    互聯網產品設計主題詞表
    java验证码识别3
    C++实现C#的get,set属性操作
    简陋,山寨,Everything,桌面搜索,原理,源码
    java验证码识别1
  • 原文地址:https://www.cnblogs.com/sky-stars/p/10964563.html
Copyright © 2020-2023  润新知