• NUMBER BASE CONVERSION(进制转换)


    Description

    Write a program to convert numbers in one base to numbers in a second base. There are 62 different digits: 
    { 0-9,A-Z,a-z } 
    HINT: If you make a sequence of base conversions using the output of one conversion as the input to the next, when you get back to the original base, you should get the original number. 

    Input

    The first line of input contains a single positive integer. This is the number of lines that follow. Each of the following lines will have a (decimal) input base followed by a (decimal) output base followed by a number expressed in the input base. Both the input base and the output base will be in the range from 2 to 62. That is (in decimal) A = 10, B = 11, ..., Z = 35, a = 36, b = 37, ..., z = 61 (0-9 have their usual meanings). 

    Output

    The output of the program should consist of three lines of output for each base conversion performed. The first line should be the input base in decimal followed by a space then the input number (as given expressed in the input base). The second output line should be the output base followed by a space then the input number (as expressed in the output base). The third output line is blank. 

    Sample Input

    8
    62 2 abcdefghiz
    10 16 1234567890123456789012345678901234567890
    16 35 3A0C92075C0DBF3B8ACBC5F96CE3F0AD2
    35 23 333YMHOUE8JPLT7OX6K9FYCQ8A
    23 49 946B9AA02MI37E3D3MMJ4G7BL2F05
    49 61 1VbDkSIMJL3JjRgAdlUfcaWj
    61 5 dl9MDSWqwHjDnToKcsWE1S
    5 10 42104444441001414401221302402201233340311104212022133030
    

    Sample Output

    62 abcdefghiz
    2 11011100000100010111110010010110011111001001100011010010001
    
    10 1234567890123456789012345678901234567890
    16 3A0C92075C0DBF3B8ACBC5F96CE3F0AD2
    
    16 3A0C92075C0DBF3B8ACBC5F96CE3F0AD2
    35 333YMHOUE8JPLT7OX6K9FYCQ8A
    
    35 333YMHOUE8JPLT7OX6K9FYCQ8A
    23 946B9AA02MI37E3D3MMJ4G7BL2F05
    
    23 946B9AA02MI37E3D3MMJ4G7BL2F05
    49 1VbDkSIMJL3JjRgAdlUfcaWj
    
    49 1VbDkSIMJL3JjRgAdlUfcaWj
    61 dl9MDSWqwHjDnToKcsWE1S
    
    61 dl9MDSWqwHjDnToKcsWE1S
    5 42104444441001414401221302402201233340311104212022133030
    
    5 42104444441001414401221302402201233340311104212022133030
    10 1234567890123456789012345678901234567890
    

    Source

    #include<cstdio>
    #include<cstring>
    using namespace std;
    int main()
    {
        int n,i,x,y,l,k,t[100],b[100];
        char s[100],ans[100];//由于超过十进制的数含有字母,因此用字符串数组储存 
        for (scanf("%d",&n);n--;)
          {
               scanf("%d%d%s",&x,&y,s);
               for (i=k=strlen(s);0<i--;)
                 t[k-1-i]=s[i]-(s[i]<58?48:s[i]<97?55:61);//ascall码48到57为字符0到一,97到122对应小写字母a到b,将字符转变成相应的十进制数存入数组t中。
               for (l=0;k;)
                 {
                       for (i=k;1<i--;)  //这一坨for循环我实在搞不懂啥意思 
                    {
                        t[i-1]+=t[i]%y*x;
                        t[i]/=y;//貌似是使除t[0]以外的变为y进制,避免了重复的运算 
                    }              
                  b[l++]=t[0]%y;//由于t[0]是最低位,相当于将t[0]作为一个独立的单位进行处理。
                  t[0]/=y;
                  for (;0<k&&!t[k-1];k--);//当t最高位为0时,缩短t的长度。 
                 }
               for (ans[l]=i=0;i<l;i++)
                ans[l-1-i]=b[i]+(b[i]<10?48:b[i]<36?55:61);
               printf("%d %s
    %d %s
    
    ",x,s,y,ans);
          }
        return 0;
     
     
    I'm so lost but not afraid ,I've been broken and raise again
  • 相关阅读:
    ElasticSearch第三步-中文分词
    centos 6.7 搭建tornado + nginx + supervisor的方法(已经实践)
    python ConfigParser 模块
    collections 模块(namedtuple, deque, Counter )
    Kali 开机报错解决方案
    debian 或者kali 安装git
    kali python pip3 的安装和卸载
    Kali 使用ssh,安装vmware tools 和字体重叠
    装饰器
    python2.7 报错(UnicodeDecodeError: 'ascii' codec can't decode byte 0xe6 in position 0: ordinal not in range(128))
  • 原文地址:https://www.cnblogs.com/sjymj/p/5189528.html
Copyright © 2020-2023  润新知