• [结题报告]11494 Queen Time limit: 1.000 seconds


     Queen 

    The Problem

    The game of Chess has several pieces with curious movements. One of them is the Queen, which can move any number of squares in any direction: in the same line, in the same column or in any of the diagonals, as illustrated by the figure below (black dots represent positions the queen may reach in one move):

    The great Chess Master Kary Gasparov invented a new type of chess problem: given the position of a queen in an empty standard chess board (that is, an 8 x 8 board) how many moves are needed so that she reaches another given square in the board?

    Kary found the solution for some of those problems, but is having a difficult time to solve some others, and therefore he has asked that you write a program to solve this type of problem.

    The Input

    The input contains several test cases. The only line of each test case contains four integers X1Y1X2 andY2 (1 ≤ X1, Y1, X2, Y2 ≤ 8). The queen starts in the square with coordinates (X1, Y1), and must finish at the square with coordinates (X2, Y2). In the chessboard, columns are numbered from 1 to 8, from left ro right; lines are also numbered from 1 to 8, from top to bottom. The coordinates of a square in line X and column Y are (X, Y).

    The end of input is indicated by a line containing four zeros, separated by spaces.

    The Output

    For each test case in the input your program must print a single line, containing an integer, indicating the smallest number of moves needed for the queen to reach the new position.

    Sample Input

    4 4 6 2
    3 5 3 5
    5 5 4 3
    0 0 0 0
    
    

    Sample Output

    1
    0
    2

    参考代码:
    题给定坐标,求西洋棋中皇后需要多少步才能到指定位置,西洋棋中皇后可以横,竖,斜走,另外不限步数,所以在棋盘的上坐标皇后最多2步即可到达.因此如果x,y相等不必走了,已经一致了,x,y任意一个相等,以及呈比例.只需一步.剩下的就是要走2步的了.
    #include<stdio.h>
    int main(void)
    {
        int x1,x2,y1,y2;
        while(scanf("%d%d%d%d",&x1,&y1,&x2,&y2)!=EOF)
        {
            if((x1==0&&x2==0)&&(y1==0&&y2==0))break;
            if(x1==x2&&y1==y2)
            printf("0\n");
            else if((y1==y2)||(x1==x2))
            printf("1\n");
            else if(((x1-x2)/(y1-y2)==-1||(x1-x2)/(y1-y2)==1)&&(x1-x2)%(y1-y2)==0)
            printf("1\n");
            else
            printf("2\n");
        }
        return 0;
    }
  • 相关阅读:
    东芝线阵CCD芯片TCD1305DG驱动时序设计
    数字电路中应避免产生不必要的锁存器 Latch
    准双向口、开漏输出、推挽输出结构介绍
    边沿检测电路小结
    数字系统中的亚稳态及其解决办法
    launch edge 和 latch edge 延迟
    基于Verilog的偶数、奇数、半整数分频以及任意分频器设计
    找到了救命的东西 NVIDIA MPS (multi-process service)
    关于多个程序同时launch kernels on the same GPU
    java的System.currentTimeMillis()和System.nanoTime()
  • 原文地址:https://www.cnblogs.com/sjy123/p/2922206.html
Copyright © 2020-2023  润新知