• [结题报告]458 The Decoder Time limit: 3.000 seconds


     The Decoder 

    Write a complete program that will correctly decode a set of characters into a valid message. Your program should read a given file of a simple coded set of characters and print the exact message that the characters contain. The code key for this simple coding is a one for one character substitution based upon a single arithmetic manipulation of the printable portion of the ASCII character set.

    Input and Output

    For example: with the input file that contains:

    1JKJ'pz'{ol'{yhklthyr'vm'{ol'Jvu{yvs'Kh{h'Jvywvyh{pvu5
    1PIT'pz'h'{yhklthyr'vm'{ol'Pu{lyuh{pvuhs'I|zpulzz'Thjopul'Jvywvyh{pvu5
    1KLJ'pz'{ol'{yhklthyr'vm'{ol'Kpnp{hs'Lx|pwtlu{'Jvywvyh{pvu5

    your program should print the message:

    *CDC is the trademark of the Control Data Corporation.
    *IBM is a trademark of the International Business Machine Corporation.
    *DEC is the trademark of the Digital Equipment Corporation.

    Your program should accept all sets of characters that use the same encoding scheme and should print the actual message of each set of characters.

    Sample Input

    1JKJ'pz'{ol'{yhklthyr'vm'{ol'Jvu{yvs'Kh{h'Jvywvyh{pvu5
    1PIT'pz'h'{yhklthyr'vm'{ol'Pu{lyuh{pvuhs'I|zpulzz'Thjopul'Jvywvyh{pvu5
    1KLJ'pz'{ol'{yhklthyr'vm'{ol'Kpnp{hs'Lx|pwtlu{'Jvywvyh{pvu5

    Sample Output

    *CDC is the trademark of the Control Data Corporation.
    *IBM is a trademark of the International Business Machine Corporation.
    *DEC is the trademark of the Digital Equipment Corporation.


    代码参考:
    本题主要是将字符串的每个部分都进行变化,通过观察可是原码和变化码之间ASCII码相差7.
    #include"stdio.h"
    void fun(char *p)    //自定义函数;  
     {  int i=0;         //定义变量i,控制循环; 
         while(p[i])      //循环解码; 
        {p[i]-=7;            
         i++;}
        p[i]='\0';          //字符串结束; 
         } 
    main()
     {    char s[30000];         //申请数组 ; 
           while(gets(s))           
             { fun(s);               //调用函数; 
               printf("%s\n",s);        //输出; 
             } 
           }    
  • 相关阅读:
    移动端 提交按钮呗软键盘挤上去的问题解决
    jenkins创建项目API踩坑记
    backstage使用笔记(2)- 跨域代理设置
    backstage使用笔记(1)- 项目的搭建和插件的创建
    什么是强缓存,什么是协商缓存?
    关于antd英文文案切换为中文
    记解决遇到自己电脑看线上项目没问题,别的同事电脑看线上项目有问题的疑难杂症
    vue.js组件传值
    Vue.js组件
    关于Object.keys()和for in的区别
  • 原文地址:https://www.cnblogs.com/sjy123/p/2881428.html
Copyright © 2020-2023  润新知