• 题目1021:统计字符


    题目描述:
    统计一个给定字符串中指定的字符出现的次数。
    输入:
    测试输入包含若干测试用例,每个测试用例包含2行,第1行为一个长度不超过5的字符串,第2行为一个长度不超过80的字符串。注意这里的字符串包含空格,即空格也可能是要求被统计的字符之一。当读到'#'时输入结束,相应的结果不要输出。
    输出:
    对每个测试用例,统计第1行中字符串的每个字符在第2行字符串中出现的次数,按如下格式输出:
    c0 n0
    c1 n1
    c2 n2
    ...
    其中ci是第1行中第i个字符,ni是ci出现的次数。
    样例输入:
    I
    THIS IS A TEST
    i ng
    this is a long test string
    #
    样例输出:
    I 2
    i 3
    5
    n 2

    g 2

    #include<iostream>
    #include<string>
    using namespace std;
    int main()
    {
    	while(true)
    	{
    		int count[1000]={0};
    		string str1,str2;
    		getline(cin,str1);
    		if(str1=="#")
    			break;
    		getline(cin,str2);
    		int k=str1.length();
    		for(int i=0;i<k;i++)
    		{
    			int j=0;
    			while(true)
    			{
    				j=str2.find(str1[i],j);
    				if(j!=-1){count[i]++;j++;}
    				else
    					break;
    			}
    			cout<<str1[i]<<' '<<count[i]<<endl;
    		}
    	}
    	return 0;
    }


    极简,专注,速度,极致
  • 相关阅读:
    Java8新特性学习笔记(一) Lambda表达式
    android游戏动画特效的一些处理
    start from here
    感知机回归
    2020/2/21
    梯度下降
    凸优化
    批量归一化和残差网络
    Momentum
    词嵌入基础
  • 原文地址:https://www.cnblogs.com/simplelifestyle/p/3761880.html
Copyright © 2020-2023  润新知