• 树6 Complete Binary Search Tree


    题目:https://pintia.cn/problem-sets/1268384564738605056/problems/1276814005115539458

    A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

    Both the left and right subtrees must also be binary search trees.

    A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

    Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

    Output Specification:

    For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

    Sample Input:

    10
    1 2 3 4 5 6 7 8 9 0
    
     

    Sample Output:

    6 3 8 1 5 7 9 0 2 4
    • The left subtree of a node contains only nodes with keys less than the node's key.
    • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.


    题解:https://www.liuchuo.net/archives/2161
    代码:

    #include <iostream>
    #include <algorithm>
    using namespace std;
    int in[1010], level[1010], n, t = 0;
    void inOrder(int root) {
        if (root >= n) return ;
        inOrder(root * 2 + 1);
        level[root] = in[t++];
        inOrder(root * 2 + 2);
    }
    int main() {
        scanf("%d", &n);
        for (int i = 0; i < n; i++)
            scanf("%d", &in[i]);
        sort(in, in + n);
        inOrder(0);
        printf("%d", level[0]);
        for (int i = 1; i < n; i++)
            printf(" %d", level[i]);
        return 0;
    }



  • 相关阅读:
    测试
    python制作
    Mysql 用法
    Day006 Java面向对象编程
    Day005 Java数组详解
    Day004 Java方法详解
    Day003 Java流程控制
    Day002 Java基础语法
    Day001 MrakDown语法 Dos命令
    4. 谈谈你对ArrayList和LinkedList 的理解
  • 原文地址:https://www.cnblogs.com/simon-chou/p/13619926.html
Copyright © 2020-2023  润新知