• 复杂度2 Maximum Subsequence Sum


    题目: https://pintia.cn/problem-sets/1268384564738605056/problems/1268385944106778625

    Given a sequence of K integers { N1​​, N2​​, ..., NK​​ }. A continuous subsequence is defined to be { Ni​​, Ni+1​​, ..., Nj​​ } where 1ijK. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

    Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

    Input Specification:

    Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (10000). The second line contains K numbers, separated by a space.

    Output Specification:

    For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

    Sample Input:

    10
    -10 1 2 3 4 -5 -23 3 7 -21
    
     

    Sample Output:

    10 1 4


    题解: https://blog.csdn.net/weixin_42449444/article/details/90111462
    代码:

        #include <bits/stdc++.h>
        using namespace std;
         
        int main()
        {
            int N;
            cin >> N;
            int a[N];
            //最大连续子序列和sum、临时的最大连续子序列和tempsum、临时的最大连续子序列的起始下标tempindex、最大连续子序列的起始下标start、最大连续子序列的结束下标end
            int sum = -1,tempsum = 0,tempindex = 0, start = 0, end = N-1;
            for(int i = 0; i < N; i++)
            {
                cin >> a[i];
                tempsum += a[i];
                if(tempsum < 0)
                {
                    tempsum = 0;
                    tempindex = i+1;
                }
                else if(tempsum > sum)
                {
                    sum = tempsum;
                    start = tempindex;
                    end = i;
                }
            }
            if(sum == -1)
            {
                sum = 0;
            }
            cout << sum << " " << a[start] << " " << a[end];
            return 0;
        }
  • 相关阅读:
    iOS 关于字体根据不同屏幕尺寸等比适配的问题(zz)
    安卓开发:一种快速提取安卓app的UI图标资源的方法
    申请邓白氏编码的时候总是提示 Enter a valid Street Address 怎么办?
    利用日期、经纬度求日出日落时间 C语言程序代码(zz)
    JS导出Excel 代码笔记
    Bootstrap系列 -- 44. 分页导航
    Bootstrap系列 -- 43. 固定导航条
    Bootstrap系列 -- 42. 导航条中的按钮、文本和链接
    Bootstrap系列 -- 41. 带表单的导航条
    Bootstrap系列 -- 40. 导航条二级菜单
  • 原文地址:https://www.cnblogs.com/simon-chou/p/13619815.html
Copyright © 2020-2023  润新知