• HDU 多校联合 6045


    Is Derek lying?

    Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
    Total Submission(s): 441    Accepted Submission(s): 266


    Problem Description
    Derek and Alfia are good friends.Derek is Chinese,and Alfia is Austrian.This summer holiday,they both participate in the summer camp of Borussia Dortmund.During the summer camp,there will be fan tests at intervals.The test consists of N choice questions and each question is followed by three choices marked “A” “B” and “C”.Each question has only one correct answer and each question is worth 1 point.It means that if your answer for this question is right,you can get 1 point.The total score of a person is the sum of marks for all questions.When the test is over,the computer will tell Derek the total score of him and Alfia.Then Alfia will ask Derek the total score of her and he will tell her: “My total score is X,your total score is Y.”But Derek is naughty,sometimes he may lie to her. Here give you the answer that Derek and Alfia made,you should judge whether Derek is lying.If there exists a set of standard answer satisfy the total score that Derek said,you can consider he is not lying,otherwise he is lying.
     
    Input
    The first line consists of an integer T,represents the number of test cases.

    For each test case,there will be three lines.

    The first line consists of three integers N,X,Y,the meaning is mentioned above.

    The second line consists of N characters,each character is “A” “B” or “C”,which represents the answer of Derek for each question.

    The third line consists of N characters,the same form as the second line,which represents the answer of Alfia for each question.

    Data Range:1N80000,0X,YN,Ti=1N300000
     
    Output
    For each test case,the output will be only a line.

    Please print “Lying” if you can make sure that Derek is lying,otherwise please print “Not lying”.
     
    Sample Input
    2
    3 1 3
    AAA
    ABC
    5 5 0
    ABCBC
    ACBCB
     
    Sample Output
    Not lying
    Lying
    统计答案不一样的数量,所以a,b得分之差小于等于dif,相等是相同的全对,同理x+y<=n*2-dif,相等情况是打出来的全对
    #include <iostream>
    #include <algorithm>
    #include <cstring>
    #include <cstdio>
    #include <vector>
    #include <cstdlib>
    #include <iomanip>
    #include <cmath>
    #include <ctime>
    #include <map>
    #include <set>
    using namespace std;
    #define lowbit(x) (x&(-x))
    #define max(x,y) (x>y?x:y)
    #define min(x,y) (x<y?x:y)
    #define MAX 100000000000000000
    #define MOD 1000000007
    #define pi acos(-1.0)
    #define ei exp(1)
    #define PI 3.141592653589793238462
    #define INF 0x3f3f3f3f3f
    #define mem(a) (memset(a,0,sizeof(a)))
    typedef long long ll;
    char a[80006],b[80006];
    int ans,dif,t,n,la,lb;
    int main()
    {
        scanf("%d",&t);
        while(t--)
        {
            scanf("%d%d%d",&n,&la,&lb);
            scanf("%s%s",&a,&b);
            ans=dif=0;
            for(int i=0;i<n;i++)
            {
                if(a[i]==b[i]) ans++;
                else dif++;
            }
            if(abs(la-lb)>dif || la+lb>n*2-dif)puts("Lying");
            else puts("Not lying");
        }
        return 0;
    }
  • 相关阅读:
    123457123457#0#-----com.threeapp.renzhepaoku01----儿童跑酷游戏(忍者版)
    123456123456#0#-----com.threeapp.xiongMaoPaoPao01----熊猫跑酷01
    123456123456#0#-----com.threeapp.JiQiRenDaZhan01----机器人大战恐龙
    HashMap的工作原理
    Java 虚拟机
    分布式之缓存系统
    分库分表之后,id 主键如何处理?
    如何设计可以动态扩容缩容的分库分表方案?
    为什么要分库分表?用过哪些分库分表中间件?不同的分库分表中间件都有什么优点和缺点?
    如何实现 MySQL 的读写分离?MySQL 主从复制原理的是啥?如何解决 MySQL 主从同步的延时问题?
  • 原文地址:https://www.cnblogs.com/shinianhuanniyijuhaojiubujian/p/7248385.html
Copyright © 2020-2023  润新知