• Humble Numbers


    http://acm.hdu.edu.cn/showproblem.php?pid=1058

    Problem Description
    A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

    Write a program to find and print the nth element in this sequence
     
    Input
    The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
     
    Output
    For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
     
    Sample Input
    1
    2
    3
    4
    11
    12
    13
    21
    22
    23
    100
    1000
    5842
    0
     
    Sample Output
    The 1st humble number is 1.
    The 2nd humble number is 2.
    The 3rd humble number is 3.
    The 4th humble number is 4.
    The 11th humble number is 12.
    The 12th humble number is 14.
    The 13th humble number is 15.
    The 21st humble number is 28.
    The 22nd humble number is 30.
    The 23rd humble number is 32.
    The 100th humble number is 450.
    The 1000th humble number is 385875.
    The 5842nd humble number is 2000000000.
            题目大致意思是说,求第n个,不能被除2,3,5,7外其他素数整除的数,理解题意是一点,还有就是看答案,注意序数的输出,不注意容易WA,本渣渣的代码纯粹是为了熟练STL,此题当然也可以暴力解决。
    #include<iostream>
    #include<set>
    using namespace std;
    string ss[11]={"th","st","nd","rd","th","th","th","th","th","th"};
    string sss[11]={"th","th","th","th","th","th","th","th","th","th"};
    long long a[5]={2,3,5,7},b[5842];
    int main()
    {
      long long n,i=1;
      set<long long>s;
      set<long long>::iterator it;
      s.insert(1);
      for(it=s.begin();it!=s.end();++it)
      {
        long long x=*it;
        b[i]=x;
        if(i==5842) break;
        for(long long j=0;j<4;j++)
        {
          long long xx=x*a[j];
          if(!s.count(xx))
          {
            s.insert(xx);
          }
        }
        i++;
      }
      while(cin>>n && n!=0)
      {
        if((n/10)%10==1){
          cout<<"The "<<n<<sss[n%10]<<" humble number is "<<b[n]<<'.'<<endl;
        }
        else {
          cout<<"The "<<n<<ss[n%10]<<" humble number is "<<b[n]<<'.'<<endl;
        }
      }
      return 0;
    }

        在这里简单澄清一个简单概念,在set中,查找可以用s.find(),也可以用s.count(),find函数若查找的数存在则返回指向该元素的迭代器,反之则超出末端迭代器,

    count函数若查找的数存在则返回1,不存在则返回0。

  • 相关阅读:
    PMP工具与技术篇--3.1.1.1 引导式研讨会(人际关系与团队技能)
    PMP工具与技术篇--3.1.1 头脑风暴(数据收集技术)--名义小组技术
    PMP工具与技术篇--3.2.2 相关方映射/表现(数据表现技术)
    py1 python介绍及环境搭建
    各种网络协议(二)
    各种网络协议(一)
    简约响应式
    博客园基本页面设置
    路飞学城web作业总结
    github自动登录
  • 原文地址:https://www.cnblogs.com/shinianhuanniyijuhaojiubujian/p/6599433.html
Copyright © 2020-2023  润新知