• 部落并查集


    L2-4 部落 (25分)

    在一个社区里,每个人都有自己的小圈子,还可能同时属于很多不同的朋友圈。我们认为朋友的朋友都算在一个部落里,于是要请你统计一下,在一个给定社区中,到底有多少个互不相交的部落?并且检查任意两个人是否属于同一个部落。

    输入格式:

    输入在第一行给出一个正整数N(≤10
    ​4
    ​​ ),是已知小圈子的个数。随后N行,每行按下列格式给出一个小圈子里的人:

    K P[1] P[2] ⋯ P[K]

    其中K是小圈子里的人数,P[i](i=1,⋯,K)是小圈子里每个人的编号。这里所有人的编号从1开始连续编号,最大编号不会超过10
    ​4
    ​​ 。

    之后一行给出一个非负整数Q(≤10
    ​4
    ​​ ),是查询次数。随后Q行,每行给出一对被查询的人的编号。

    输出格式:

    首先在一行中输出这个社区的总人数、以及互不相交的部落的个数。随后对每一次查询,如果他们属于同一个部落,则在一行中输出Y,否则输出N。

    输入样例:

    4
    3 10 1 2
    2 3 4
    4 1 5 7 8
    3 9 6 4
    2
    10 5
    3 7
    

    输出样例:

    10 2
    Y
    N
    

    并查集忘的差不多了。明天巩固巩固!!!

    #include<iostream>
    #include<set>
    using namespace std;
     
    int pre[100050];
    void  init(){
        for(int i = 1; i <= 100050; i++) pre[i] = i;
    }
    int unionsearch(int root) //查找根结点
    {
        int son, tmp;
        son = root;
        while(root != pre[root]) //我的上级不是掌门
            root = pre[root];
        while(son != root) //我就找他的上级,直到掌门出现
        {
            tmp = pre[son];
            pre[son] = root;
            son = tmp;
        }
        return root; //掌门驾到~~
    }
    void inherit(int x,int y){
        int X =	unionsearch(x);
        int Y = unionsearch(y);
        if(X != Y) pre[X] = Y;
    }
    int main(){
        int n,k,a,b;
        set<int >num_f,num_p; //统计人数和部落数
        cin>>n;
        init();
        while(n--){
            cin>>k>>a;
            num_p.insert(a);
            for(int i = 1; i < k; i++){
                cin>>b;
                num_p.insert(b);
                inherit(a, b); //两个人合并到一个部落 
            }
        }
        for(int i = 1; i <= num_p.size(); i++){
            num_f.insert(unionsearch(i));	
        }
        cout<<num_p.size()<<" "<<num_f.size()<<endl;
        cin>>n;
        
        
        while(n--){
            cin>>a>>b;
            if(unionsearch(a) == unionsearch(b)) cout<<"Y"<<endl;
            else cout<<"N"<<endl;
        }
        return 0;
    }
    
  • 相关阅读:
    Codeforces467C George and Job
    Codeforces205E Little Elephant and Furik and RubikLittle Elephant and Furik and Rubik
    Codeforce205C Little Elephant and Interval
    51nod1829 函数
    51nod1574 排列转换
    nowcoder35B 小AA的数列
    Codeforce893E Counting Arrays
    gym101612 Consonant Fencity
    CodeForces559C Gerald and Giant Chess
    CodeForces456D A Lot of Games
  • 原文地址:https://www.cnblogs.com/shenxiaodou/p/12423298.html
Copyright © 2020-2023  润新知