• poj3295


    Tautology
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 11579   Accepted: 4392

    Description

    WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

    • p, q, r, s, and t are WFFs
    • if w is a WFF, Nw is a WFF
    • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
    The meaning of a WFF is defined as follows:
    • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
    • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
    Definitions of K, A, N, C, and E
         w  x   Kwx   Awx    Nw   Cwx   Ewx
      1  1   1   1    0   1   1
      1  0   0   1    0   0   0
      0  1   0   1    1   1   0
      0  0   0   0    1   1   1

    tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.

    You must determine whether or not a WFF is a tautology.

    Input

    Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

    Output

    For each test case, output a line containing tautology or not as appropriate.

    Sample Input

    ApNp
    ApNq
    0

    Sample Output

    tautology
    not

    Source


    大致题意:
    输入由p、q、r、s、t、K、A、N、C、E共10个字母组成的逻辑表达式,
    其中p、q、r、s
    、t的值为1(true)或0(false),即逻辑变量;
    K、A、N、C、E为逻辑运算符,
    K --> and:x && y
    A --> or:x || y
    N --> not :! x
    C --> implies :(!x)||y
    E --> equals :x==y
    问这个逻辑表达式是否为永真式。
    PS:输入格式保证是合法的
    思路:
    对于逻辑变量的每个取值,都依次枚举 判断对于每一种逻辑变量的取值情况表达式是否为真

    #include<iostream>
    using namespace std;
    int cnt;
    char str[101];
    bool step(char str[101],int tk){
        cnt++;
        switch(str[cnt]){
            case 'p':return tk&1;
            case 'q':return(tk>>1)&1;
            case 'r':return(tk>>2)&1;
            case 's':return(tk>>3)&1;
            case 't':return(tk>>4)&1;
            case 'N':return !step(str,tk);
            case 'K':return step(str,tk)&step(str,tk);
            case 'A':return step(str,tk)|step(str,tk);
            case 'C':return !step(str,tk)|step(str,tk);
            case 'E':return step(str,tk)==step(str,tk);
        }
    }
    bool judge(char str[101]){
        for(int i=0;i<32;i++){
            cnt=-1;
            if(!step(str,i)) return 0;    
        }
        return 1;
    }
    int main(){
        while(cin>>str){   
            if(str[0]=='0') break;
            if(judge(str))
                cout<<"tautology"<<endl;
            else
                cout<<"not"<<endl;
        }
        return 0;
    }
  • 相关阅读:
    svg文件使用highmap显示
    动静分离
    angular 零碎
    使用doxmate生成文档
    javascript之console篇
    java 中String与StringBuilder 效率
    highcharts 组合chart
    js 攻坚克难
    html base 又一重大发现
    sql 分析 依赖beanutils
  • 原文地址:https://www.cnblogs.com/shenben/p/5646335.html
Copyright © 2020-2023  润新知