• poj2503


    Babelfish
    Time Limit: 3000MS   Memory Limit: 65536K
    Total Submissions: 39585   Accepted: 16891

    Description

    You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

    Input

    Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

    Output

    Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

    Sample Input

    dog ogday
    cat atcay
    pig igpay
    froot ootfray
    loops oopslay
    
    atcay
    ittenkay
    oopslay
    

    Sample Output

    cat
    eh
    loops
    

    Hint

    Huge input and output,scanf and printf are recommended.

    Source

    #include<cstdio>
    #include<cstring>
    #include<string>
    #include<iostream>
    #include<map>
    using namespace std;
    map<string,string>m;
    char s[30],x[11],y[11];
    int main(){
        while(1){
            gets(s);
            if(s[0]=='') break;
            sscanf(s,"%s %s",x,y);//分割 
            m[y]=x;
        }
        while(gets(y)){
            if(m[y]=="") cout<<"eh"<<endl;
            else cout<<m[y]<<endl;
        }
        return 0;
    }
  • 相关阅读:
    layout布局
    窗口、easyui-window、easyui-panel、easyui-linkbutton
    FASTJSON
    Insert title here
    Insert title here
    Scala并发编程
    scala中java并发编程
    scala调用外部命令
    scala正则表达式
    scala占位符_的用法
  • 原文地址:https://www.cnblogs.com/shenben/p/5619304.html
Copyright © 2020-2023  润新知