• Poj3087


    Shuffle'm Up
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 8842   Accepted: 4077

    Description

    A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.

    The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:

    The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom of S1 and so on until the topmost chip from S1 is placed on top of S12.

    After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12 to form a new S2. The shuffle operation may then be repeated to form a newS12.

    For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

    Input

    The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

    Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of theC chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A throughH). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

    Output

    Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

    Sample Input

    2
    4
    AHAH
    HAHA
    HHAAAAHH
    3
    CDE
    CDE
    EEDDCC

    Sample Output

    1 2
    2 -1

    Source

     
    题目大意:  已知两堆牌s1和s2的初始状态, 其牌数均为c,按给定规则能将他们相互交叉组合成一堆牌s12,再将s12的最底下的c块牌归为s1,最顶的c块牌归为s2,依此循环下去。    现在输入s1和s2的初始状态 以及 预想的最终状态s12  问s1 s2经过多少次洗牌之后,最终能达到状态s12,若永远不可能相同,则输出"-1"。    
    解题思路:  很浅白的模拟题= = 不懂为什么别人要把它归类到广搜。。。所以我又重新分类了。。。 
    代码:
    #include<cstdio>
    #include<cstring>
    #include<iostream>
    using namespace std;
    #define N 1010
    char s1[N],s2[N],str[N],shuffle[N],goal[N];
    int x,n;
    inline int dfs(){
        int step=0,x,y,i;
        for(;;){
            step++;
            x=y=0;
            for(int i=0;i<2*n;i++){
                if(i%2==0)
                    shuffle[i]=s2[x++];    
                else
                    shuffle[i]=s1[y++];        
            }    
            shuffle[2*n]='';
            if(strcmp(shuffle,goal)==0) return step;
            if(strcmp(shuffle,str)==0)  return -1;
            strncpy(s1,shuffle,n);
            s1[n]='';
            strncpy(s2,shuffle+n,n);
            s2[n]='';    
        }
    }
    int main(){
        cin>>x;
        for(int t=1;t<=x;t++){
            cin>>n;
            cin>>s1>>s2>>goal;
            strncpy(str,s1,n);
            strncpy(str+n,s2,n);
            str[2*n]='';
            cout<<t<<" "<<dfs()<<endl;
        }
        return 0;
    }
  • 相关阅读:
    Mysql元数据分析
    python编码encode和decode
    自己写的Python数据库连接类和sql语句拼接方法
    【甘道夫】Sqoop1.99.3基础操作--导入Oracle的数据到HDFS
    SVN配置以及自己主动部署到apache虚拟文件夹
    css中使用id和class 的不同
    Android OpenGL ES(七)----理解纹理与纹理过滤
    一键安装 redmine on windows 和发邮件设置
    足球大数据:致足球怀疑论者-The Counter(s)-Reformation反教条改革
    【Android进阶篇】Fragment的两种载入方式
  • 原文地址:https://www.cnblogs.com/shenben/p/5575833.html
Copyright © 2020-2023  润新知