• 1003 Max Sum


    Max Sum

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 353912    Accepted Submission(s): 84524


    Problem Description
    Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
     
    Input
    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
     
    Output
    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
     
    Sample Input
    2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
     
    Sample Output
    Case 1: 14 1 4 Case 2: 7 1 6
     
    AC代码:
    #include<iostream>
    #include<vector>
    #include<algorithm>
    using namespace std;
    int main()
    {
        int n, m, val, i, sum, j ,summax,left,rigth,tmp;
        vector<int> v;
        while (cin>>n)
        {
            for (i = 0; i < n; i++) {
                cin >> m;
                v.clear();
                for (j = 0; j < m; j++) {
                    cin >> val;
                    v.push_back(val);
                }
                sum = 0;
                summax = INT_MIN;
                left = rigth = 0;
                tmp = 0;
                for (j = 0; j < m; j++) {
                    sum +=  v[j];
                    if (sum > summax) {
                        summax = sum;
                        rigth = j;
                        left = tmp;
                    }
                    if (sum < 0) {
                        sum = 0;
                        tmp = j + 1;
                    }
                    
                }
                cout << "Case " << i+1<< ":" << endl;
                cout << summax << " " << left +1<< " " << rigth +1 << endl;
                if (i != n - 1) {
                    cout << endl;
                }
            }
        }
        return 0;
    }
  • 相关阅读:
    团队项目——地铁信息查询数据结构设计
    用Visio画UML顺序图
    用Visio画UML用例图
    结对编程项目进展——第四周
    结对编程项目进展——第三周
    结对项目进展第一周——初步认识结对编程
    个人项目四则运算生成程序进展——第三周
    hbase各种遍历查询shell语句 包含过滤组合条件
    linux c段错误分析方法
    SMB SMB2 协议wiki
  • 原文地址:https://www.cnblogs.com/shao-qi/p/13173564.html
Copyright © 2020-2023  润新知