• poj1704 Georgia and Bob


    Language:
    Georgia and Bob
    Time Limit: 1000MS Memory Limit: 10000K
    Total Submissions: 11915 Accepted: 3956
    Description

    Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, …, and place N chessmen on different grids, as shown in the following figure for example:

    Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game.

    Georgia always plays first since “Lady first”. Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out.

    Given the initial positions of the n chessmen, can you predict who will finally win the game?
    Input

    The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 … Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.
    Output

    For each test case, prints a single line, “Georgia will win”, if Georgia will win the game; “Bob will win”, if Bob will win the game; otherwise ‘Not sure’.
    Sample Input

    2
    3
    1 2 3
    8
    1 5 6 7 9 12 14 17
    Sample Output

    Bob will win
    Georgia will win

    题目大意

    Georgia和Bob在玩一种自创的游戏。一个棋盘上有N个旗子(1 <= N <= 1000),第i个棋子的位置Pi(1 <= Pi <= 10000)。现在Georgia先走。每个人每一次可以把一枚棋子向左移动任意个格子,但是不能超越其他棋子,也不能和其他棋子处在同一个格子里。如果轮到某一个人的时候Ta再也不能移动棋子了,就判负。
    

    题解

    阶梯博弈,先算出每个棋可以移的最大步数,最后可以转换成给定N堆石子,每堆里面的石子个数都是非负的。每次可以把第i堆中的任意颗石子移动到第i + 1堆中(1 <= i < N),或者第N堆的石子扔掉任意颗。如果某人不能继续操作则判负的问题。
    

    代码

    #include<iostream>
    #include<cstdio>
    #include<algorithm>
    
    const int MAXN = 1005;
    using namespace std;
    
    int n,a[MAXN],ans,T,b[MAXN];
    
    int main(){
        scanf("%d",&T);
        while(T--){
            scanf("%d",&n);ans=0;
            for(register int i=1;i<=n;i++)
                scanf("%d",&a[i]);
            sort(a+1,a+1+n);
            for(register int i=1;i<=n;i++)
                b[i]=a[i]-a[i-1]-1;
            for(register int i=n;i>=1;i-=2)
                ans^=b[i];
            if(ans) cout<<"Georgia will win"<<endl;
            else cout<<"Bob will win"<<endl;
        }
        return 0;
    }
  • 相关阅读:
    VBS控制鼠标移动和点击(附源代码下载)
    用VBS控制鼠标的实现代码(获取鼠标坐标、鼠标移动、鼠标单击、鼠标双击)
    vbs鼠标方法——模拟鼠标按键
    vbs 获取当前目录的实现代码
    如何在VBS脚本中显示“选择文件对话框”或“选择目录对话框”
    loadrunner使用socket协议来实现客户端对服务器产生压力实例。(通过发送心跳包,达到连接多个客户端的目的)
    loadunner使用socket协议来实现多客户端连接同一服务器脚本(使用到IP欺骗技术)
    Loadrunner中参数和变量的使用
    LoadRunner学习知多少--IP欺骗使用
    Linux下tar bz gz等压缩包的压缩和解压
  • 原文地址:https://www.cnblogs.com/sdfzsyq/p/9677061.html
Copyright © 2020-2023  润新知