• 【多校联合】(HDU6043)KazaQ's Socks


    【多校联合】(HDU6043)KazaQ’s Socks

    一条纯粹的水题,记录下只是因为自己错的太多而已。
    原因在于对数据的细节的把握不佳。

    原题

    KazaQ’s Socks

    • Time Limit: 2000/1000 MS (Java/Others)
    • Memory Limit: 131072/131072 K (Java/Others)

    Problem Description

    KazaQ wears socks everyday.

    At the beginning, he has n pairs of socks numbered from 1 to n in his closets.

    Every morning, he puts on a pair of socks which has the smallest number in the closets.

    Every evening, he puts this pair of socks in the basket. If there are n−1 pairs of socks in the basket now, lazy KazaQ has to wash them. These socks will be put in the closets again in tomorrow evening.

    KazaQ would like to know which pair of socks he should wear on the k-th day.

    Input

    The input consists of multiple test cases. (about 2000)

    For each case, there is a line contains two numbers n,k (2≤n≤109,1≤k≤1018).

    Output

    For each test case, output “Case #x: y” in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.

    Sample Input

    3 7
    3 6
    4 9

    Sample Output

    Case #1: 3
    Case #2: 1
    Case #3: 2

    代码

    #include <iostream>
    #include <bits/stdc++.h>
    using namespace std;
    
    typedef long long ll;
    
    
    int main()
    {
        ll n,k,kase=0;
        while(cin>>n>>k)
        {
            cout<<"Case #"<<++kase<<": ";
            if(k>n)
            {
                k-=n;
                int flag=(k/(n-1)+1)%2;
                if(flag)
                    cout<<int(k%(n-1)==0?n:k%(n-1))<<endl;
                else cout<<int(k%(n-1)==0?n-1:k%(n-1))<<endl;
            }
            else cout<<k<<endl;
        }
        return 0;
    } 

    Original Address

    如非注明,原创内容遵循GFDLv1.3发布;其中的代码遵循GPLv3发布。
  • 相关阅读:
    Ubuntu的网络共享
    一次网络请求是如何实现的
    一次web请求发生的神奇故事
    Header解析
    Shiro入门指引
    Shiro入门资源整理
    Shiro在SpringBoot中的使用
    Shiro源码解析-Session篇
    Shiro源码解析-登录篇
    9.nginx使用redis用缓存
  • 原文地址:https://www.cnblogs.com/samhx/p/9652115.html
Copyright © 2020-2023  润新知