• hdu 1004 shui


    Let the Balloon Rise

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 65716    Accepted Submission(s): 24329


    Problem Description
    Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

    This year, they decide to leave this lovely job to you.
     
    Input
    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

    A test case with N = 0 terminates the input and this test case is not to be processed.
     
    Output
    For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
     
    Sample Input
    5 green red blue red red 3 pink orange pink 0
     
    Sample Output
    red pink
     
    Author
    WU, Jiazhi
     
    Source
     
    Recommend
    JGShining   |   We have carefully selected several similar problems for you:  1008 1005 1009 1019 1021
    import java.util.Scanner;
    
    //import java.util.HashMap;
    //import java.util.Map;
    //import java.util.Scanner;
    //
    //public class Main {
    //	/**
    //	 * @param args
    //	 */
    //	public static void main(String[] args) {
    //		// TODO Auto-generated method stub
    //		Scanner sc = new Scanner(System.in);
    //		while(true){
    //			int n = sc.nextInt();
    //			if(n==0) break;
    //			String maxS="";
    //			int max=0;
    //			Map<String, Integer> m = new HashMap<String,Integer>();
    //			for(int i=0; i<n; i++){
    //				String s = sc.next();
    //				if(m.containsKey(s))
    //					m.put(s, m.get(s)+1);
    //				else m.put(s, 1);
    //				if(m.get(s)>max){
    //					max=m.get(s);
    //					maxS=s;
    //				}
    //			}
    //			System.out.println(maxS);
    //		}
    //	}
    //
    //}
    
    
    public class Main{
    	public static void main(String[] args){
    		Scanner sc = new Scanner(System.in);
    		while(true){
    			int n=sc.nextInt();
    			if(n==0) break;
    			String[] s = new String[n+1];
    			String pop="";
    			int ip = 0;
    			for(int i=0; i<n; i++) s[i]=sc.next();
    			for(int i=0; i<n; i++){
    				String t = s[i];
    				int cnt=0;
    				for(int j=0; j<n; j++)
    					if(t.equals(s[j]))
    						cnt++;
    				if(cnt>ip){
    					ip=cnt;
    					pop=t;
    				}
    			}
    			System.out.println(pop);
    		}
    	}
    }
    
  • 相关阅读:
    Java中List集合去除重复数据的六种方法
    常见的Redis面试"刁难"问题,值得一读
    以Integer类型传参值不变来理解Java值传参
    Linux系统安装snmp服务
    直接取数据到RANGE
    SAP翔子_2019集结号
    销售订单BOM组件分配(CP_BD_DIRECT_INPUT_PLAN_EXT)
    SAP翔子_webservice篇索引
    函数篇3 EXCEL导入函数去除行数限制
    ABAP基础篇4 常用的字符串操作语法
  • 原文地址:https://www.cnblogs.com/ramanujan/p/3582410.html
Copyright © 2020-2023  润新知