• hdu 1003 dp


                  Max Sum

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 128098    Accepted Submission(s): 29672


    Problem Description
    Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
     
    Input
    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
     
    Output
    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
     
    Sample Input
    2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
     
    Sample Output
    Case 1: 14 1 4 Case 2: 7 1 6
     
    Author
    Ignatius.L
     
    Recommend
    We have carefully selected several similar problems for you:  1176 1087 1069 2084 1058
     
    又来水题了
    2bb的错误,想不出的状态方程。。。
    import java.util.Scanner;
    
    
    public class Main {
    
        /**
         * @param args
         */
        public static void main(String[] args) {
            // TODO Auto-generated method stub
            Scanner sc = new Scanner(System.in);
            int T = sc.nextInt();
            for(int i=0; i<T; i++){
                int n = sc.nextInt();
                int[] dp = new int[n+1], a = new int[n+1];
                for(int j=0; j<n; j++) a[j]=sc.nextInt();
                int maxSum=a[0], right=0, left=0;
                for(int j=0; j<n; j++){ 
                    dp[j]=Math.max((j==0?0:dp[j-1]), 0)+a[j];
                    if(dp[j]>maxSum){
                        maxSum=dp[j];    right=j;
                    }
                }
                for(int j=right; j>-1; j--){
                    dp[j]=Math.max((j==right?0:dp[j+1]), 0)+a[j];
                    if(maxSum==dp[j])
                        left=j;
                }
                if(i>0) System.out.println();
                System.out.println("Case "+(i+1)+":");
                System.out.println(maxSum+" "+(++left)+" "+(++right));
            }
        }
    }
    
  • 相关阅读:
    解决U3D4.1.5或以上无法启动MONODEV的方法
    unity的List构造函数在IOS平台存在缺陷
    【Python爬虫】性能提升
    【JavaScript+jQuery】JavaScript权威指南读书笔记1
    【Python爬虫】爬虫的基本修养
    【Python基础】Python yield 用法
    【Python进阶】回调函数
    【Python基础】Python输出终端的颜色显示
    【python进阶】并发编程-线程进程协程
    【项目实战开发】密码加密处理后登录验证
  • 原文地址:https://www.cnblogs.com/ramanujan/p/3582260.html
Copyright © 2020-2023  润新知