• hdu 5774 Where Amazing Happens 水题


    Where Amazing Happens

    题目连接:

    http://acm.hdu.edu.cn/showproblem.php?pid=5774

    Description

    As the premier men's professional basketball league in the world, the National Basketball Association (NBA) has witnessed many superstars, legendary teams and precious friendships.

    Here is a list of every season’s champion from the league's inception in 1946 to 2015.

    Season Champion
    2015-16 Cleveland Cavaliers
    2014-15 Golden State Warriors
    2013-14 San Antonio Spurs
    2012-13 Miami Heat
    2011-12 Miami Heat
    2010-11 Dallas Mavericks
    2009-10 L.A. Lakers
    2008-09 L.A. Lakers
    2007-08 Boston Celtics
    2006-07 San Antonio Spurs
    2005-06 Miami Heat
    2004-05 San Antonio Spurs
    2003-04 Detroit Pistons
    2002-03 San Antonio Spurs
    2001-02 L.A. Lakers
    2000-01 L.A. Lakers
    1999-00 L.A. Lakers
    1998-99 San Antonio Spurs
    1997-98 Chicago Bulls
    1996-97 Chicago Bulls
    1995-96 Chicago Bulls
    1994-95 Houston Rockets
    1993-94 Houston Rockets
    1992-93 Chicago Bulls
    1991-92 Chicago Bulls
    1990-91 Chicago Bulls
    1989-90 Detroit Pistons
    1988-89 Detroit Pistons
    1987-88 L.A. Lakers
    1986-87 L.A. Lakers
    1985-86 Boston Celtics
    1984-85 L.A. Lakers
    1983-84 Boston Celtics
    1982-83 Philadelphia 76ers
    1981-82 L.A. Lakers
    1980-81 Boston Celtics
    1979-80 L.A. Lakers
    1978-79 Seattle Sonics
    1977-78 Washington Bullets
    1976-77 Portland Trail Blazers
    1975-76 Boston Celtics
    1974-75 Golden State Warriors
    1973-74 Boston Celtics
    1972-73 New York Knicks
    1971-72 L.A. Lakers
    1970-71 Milwaukee Bucks
    1969-70 New York Knicks
    1968-69 Boston Celtics
    1967-68 Boston Celtics
    1966-67 Philadelphia 76ers
    1965-66 Boston Celtics
    1964-65 Boston Celtics
    1963-64 Boston Celtics
    1962-63 Boston Celtics
    1961-62 Boston Celtics
    1960-61 Boston Celtics
    1959-60 Boston Celtics
    1958-59 Boston Celtics
    1957-58 St. Louis Hawks
    1956-57 Boston Celtics
    1955-56 Philadelphia Warriors
    1954-55 Syracuse Nats
    1953-54 Minneapolis Lakers
    1952-53 Minneapolis Lakers
    1951-52 Minneapolis Lakers
    1950-51 Rochester Royals
    1949-50 Minneapolis Lakers
    1948-49 Minneapolis Lakers
    1947-48 Baltimore Bullets
    1946-47 Philadelphia Warriors

    (quoted from http://www.nba.com/history/nba-season-recaps/)

    Given the team name, it won’t be difficult for you to count how many times this team(with exactly the same name) has made amazing happen.

    Input

    The first line gives the number of test cases. Each case contains one string S representing the team to be queried.
    T<=30.S consists of English letters, digits, punctuations and spaces. And 1<=length(S)<=30.

    Output

    For each test case, output one line containing "Case #x: y", where x is the test case number (starting from 1) and y is the times this team has won the championship according to the list above.

    Sample Input

    2
    Cleveland Cavaliers
    Oklahoma City Thunder

    Sample Output

    Case #1: 1
    Case #2: 0

    Hint

    题意

    给你个队名,问你这个队拿了多少次NBA总冠军

    题解:

    复制下来,然后输出一下就好了。。。

    代码

    #include <bits/stdc++.h>
    #define rep(a,b,c) for(int (a)=(b);(a)<=(c);++(a))
    #define drep(a,b,c) for(int (a)=(b);(a)>=(c);--(a))
    #define pb push_back
    #define mp make_pair
    #define sf scanf
    #define pf printf
    #define two(x) (1<<(x))
    #define clr(x,y) memset((x),(y),sizeof((x)))
    #define dbg(x) cout << #x << "=" << x << endl;
    const int mod = 1e9 + 7;
    int mul(int x,int y){return 1LL*x*y%mod;}
    int qpow(int x , int y){int res=1;while(y){if(y&1) res=mul(res,x) ; y>>=1 ; x=mul(x,x);} return res;}
    inline int read(){int x=0,f=1;char ch=getchar();while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}return x*f;}
    using namespace std;
    const int maxn = 1e5 + 15;
    
    string str[] = {"Cleveland Cavaliers",
    "Golden State Warriors",
    "San Antonio Spurs",
    "Miami Heat",
    "Miami Heat",
    "Dallas Mavericks",
    "L.A. Lakers",
    "L.A. Lakers",
    "Boston Celtics",
    "San Antonio Spurs",
    "Miami Heat",
    "San Antonio Spurs",
    "Detroit Pistons",
    "San Antonio Spurs",
    "L.A. Lakers",
    "L.A. Lakers",
    "L.A. Lakers",
    "San Antonio Spurs",
    "Chicago Bulls",
    "Chicago Bulls",
    "Chicago Bulls",
    "Houston Rockets",
    "Houston Rockets",
    "Chicago Bulls",
    "Chicago Bulls",
    "Chicago Bulls",
    "Detroit Pistons",
    "Detroit Pistons",
    "L.A. Lakers",
    "L.A. Lakers",
    "Boston Celtics",
    "L.A. Lakers",
    "Boston Celtics",
    "Philadelphia 76ers",
    "L.A. Lakers",
    "Boston Celtics",
    "L.A. Lakers",
    "Seattle Sonics",
    "Washington Bullets",
    "Portland Trail Blazers",
    "Boston Celtics",
    "Golden State Warriors",
    "Boston Celtics",
    "New York Knicks",
    "L.A. Lakers",
    "Milwaukee Bucks",
    "New York Knicks",
    "Boston Celtics",
    "Boston Celtics",
    "Philadelphia 76ers",
    "Boston Celtics",
    "Boston Celtics",
    "Boston Celtics",
    "Boston Celtics",
    "Boston Celtics",
    "Boston Celtics",
    "Boston Celtics",
    "Boston Celtics",
    "St. Louis Hawks",
    "Boston Celtics",
    "Philadelphia Warriors",
    "Syracuse Nats",
    "Minneapolis Lakers",
    "Minneapolis Lakers",
    "Minneapolis Lakers",
    "Rochester Royals",
    "Minneapolis Lakers",
    "Minneapolis Lakers",
    "Baltimore Bullets",
    "Philadelphia Warriors",
    };
    
    int main(int argc,char *argv[]){
        int T,cas=0;
        sf("%d",&T);getchar();
        while(T--){
            string s;
            getline( cin , s );
            int ans = 0;
            rep(i,0,69) if( s == str[i] ) ++ ans;
            pf("Case #%d: %d
    ",++cas,ans);
        }
        return 0;
    }
  • 相关阅读:
    Java高并发(1)
    Java基础知识之常见关键字(1)
    jQuery中attr()与prop()区别介绍
    win7下delphi中的help文档问题
    Delphi TMemo 可以显示、编辑多行文本
    TcxGrid
    Delphi学习手记——单引号和双引号的区别
    sql 系统表协助集合
    VCL安装有哪几种方法?
    sqlserver2008 服务器实例连接
  • 原文地址:https://www.cnblogs.com/qscqesze/p/5715896.html
Copyright © 2020-2023  润新知